Difficulty setting Hummingbird NGINX Browser caching

Hi,
I tried to follow the WPMU to optimise browser caching by setting the exoiry to 8 days by adding the generated code into the http section of the NGINX.conf.
I could not find this file on my server. so contacted Siteground, my server host, and received the reply below.
Your directions are to contact WPMU support if there are any difficullties. I would classify this as a difficulty. What do you suggest?
I already use the caching that Siteground suggest, but I dont think these are to do with browser caching, but server caching.
Presumably this will be a common issue and showstopper with shared server services?

Response from Siteground:
Hello Paul,

Thank you for contacting our help desk.

Unfortunately, due to the nature of shared severs, the nginx.conf file cannot be modified. That way we can preserve the stability and security of the server and therefore the stability and security of all the clients on the server.

If you would like to improve browser caching, you should consider making use of Leverage browsing caching.

You should also consider using our SuperCacher tool: cPanel > SuperCacher > Level 1 Static Cache > ON

To enable our SuperCacher's Level 2 Dynamic Caching you will have to install a plugin on each of your applications first:

https://wordpress.org/plugins/sg-cachepress/

After you install the pluigin and activate it via your WP Dashboard, go to your cPanel > SuperCacher > Level 2: Dynamic Cache and turn on the cacher there (for all websites) as well.

You can learn more about our SuperCache tool here:

https://www.siteground.com/tutorials/supercacher/

We also have a comprehensive article on how to reduce account executions overall:

https://www.siteground.com/tutorials/websiteperformance/reduce-executions.htm

If you happen to have any issues with optimizing your website with the above-mentioned methods, please feel free to contact us again and we will assist you along the way.

Best Regards,

Tsvetan Varbanov
Technical Support Team

  • Adam Czajczyk

    Hello Paul,

    I hope you're well today and thank you for your question!

    The WP Hummingbird can handle browser caching but this requires some configuration changes. In case of Apache web server this usually requires only a few additional lines in ".htaccess" file for your site. The nginx server however doesn't use it and the only way is the way suggested in plugin (changing nginx config).

    Unfortunately, some hosting providers (especially in case of shared servers) may not allow this and in such case there's no easy way to override it. I think that either following SiteGround's suggestions here would be the way to go or alternatively you may want to implement CDN (e.g. CloudFlare) for your site.

    CloudFlare does include both browser caching and gzip compression and this would work independently of your server (no need to change server config).

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Paul,

    I hope you're well today.

    The Hummingbird should work with Cloudflare. There'd be no need to enable browser caching and gzip compression though as those then would be handled by Cloudflare and enabling them on both "stages" (Cloudflare AND your site) could cause issues.

    Apart from this, there's no reason to avoid using Hummingbird with Cloudflare.

    I hope that helps.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.