Directory not being created when installed and activated

I installed the plugin, network activated it, but it didn't create a page called "Sites".
When I tried to do it manually by creating a page with the slug "blogs", it created a blank page.
The settings didn't show up either.

How do I fix this?

My site is athletesrise.com

  • Patrick
    • Support Monkey

    Hey there @Johnny

    Welcome to WPMU DEV, glad to have you aboard!

    I just tested network-activating the Blogs Directory plugin with the Fixer theme active on the main site in my test network (that is the Upfront theme I believe you are using on your site).

    Indeed, a page with the /blogs slug does not get auto-created. However, once I manually created that page and set the slug to /blogs, my directory does appear as expected at the expected URL:
    http://pcwriter.net/blogs/

    I see you do not appear to have the WPMU DEV Dashboard installed on that site. So I presume you had uploaded the plugin either via FTP, or via Plugins > Add New in your network admin. Can you please confirm which method you used?

    Also, please try deactivating the Blogs Directory plugin, and delete the /blogs page you created. Then enable a default theme (like Twenty-Fifteen), and network-activate the Blogs Directory plugin again to see if the required page gets auto-created and has the expected content.

    If not, please install the WPMU DEV Dashboard on that site, and enable support access as seen here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    We would be happy to pop into your site to help you figure this out. Thanks!

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Johnny

    Hope you are doing good today :slight_smile:

    Will activating a different theme cause me to lose all the changes I made to the current one?

    No! All your customizations/changes of upfront theme are saved in database, and will be safe after switching the theme.

    I can not see the support access activated on any of your registered website with us? Have you enabled it yet ?

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

  • Patrick
    • Support Monkey

    Hi again @Johnny ...the other one :slight_smile:

    I hope you had a great weekend!

    Indeed it helps to enable support access on the right site, lol.

    I just logged into your athletesrise.com site and installed the Blogs Directory plugin via the WPMU DEV Dashboard.

    I saw you had already created a Sites page with the blogs slug, so no need to create a new one. Your site directory now works just fine at http://athletesrise.com/blogs/

    I hope this helps! And thanks for being a member :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.