Directory Plug-in a Nightmare

Guys,

Tried installing this and could not complete set up steps as when I go to step 2 create categories I get an “invalid taxonomies” error message.

If I go to vindirect.co.nz/magazine/vintellect/listings I get a blank page – I guess because there are no categories set up.

Any ideas as to why Im getting the taxonomies error?

I have installed custompress plug-in but not yet set up any custom fields.

I am using a Gabfire (Atrs and Letters) theme.

Cheers

Paul

  • Arun Basil Lal
    • New Recruit

    Hey Paul,

    Welcome to the Community!

    I suppose you are on a single install and not a WordPress multisite. Go into CustomPress > Taxonomies Tab and see if these two exist.

    listing_category and listing_tag.

    If they do not exist, try deactivating the plugin and then reactivate it. Or simply create them. Screenshots of the settings page is attached.

    Let me know how that goes.

  • pauln
    • New Recruit

    Hi Arun,

    I am on Multi-site install. I have deactivated and deleted the plug-in for now as its also interfering with the menu structure on my Gabfire theme.

    Even though I have un-installed the Directory menu still appears on my sites.

    Any idea how to revove this. It also appears to have added /blog/ into my url structure so now I cannot get to my category pages??

    Cheers

    PAul

  • uc
    • The Incredible Code Injector

    Hi Pauln,

    Hope you are using the the latest version. If so don't install another CustomPress as Directory plugin installs CustomPress as well when activated.

    Now try this

    Activate Directory on the main-site (not at network level)

    Go to Network admin->Custompress-> setting->check "enable sub-site content".

    and put a check mark on "Remove network-wide content types from sub-sites"

    see screenshot

    UC

  • pauln
    • New Recruit

    Arun,

    I’d like to start with a clean install of Directory Plug-in as Ive deleted the directory and custompress plug-ins.

    Before I do however, I see that I still have the Directory links in the menu on my sites and I want to remove these first.

    Paul

  • uc
    • The Incredible Code Injector

    you can remove the directory menu items but that will not make much of a difference

    Just activate only Directory, Custompress will be installed as well (remember don’t do a separate custompress install.)

    Then follow the direction above

    UC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.