Directory Plugin Activation Adds CustomPress to Sidebar

Hi,

When activating the Directory plugin (with CustomPress not installed on my multisite network) it shows a CustomPress navigation menu on my admin sidebar instead of the Directory menu. I’ve tried completely uninstalling and deleting the Directory Plugin (even the WPMUDev Dashboard plugin too) and re-installing to no avail. Would really appreciate some help here.

  • Milan
    • WordPress Wizard

    Hello Kelley ,

    Hope you are doing well today and thanks for asking us. :slight_smile:

    Yes its bug and I am able to replicate it, I’ve flagged our developer and hopefully they will very soon start their work. Once their would be any update on this, you’ll get notified here. :slight_smile:

    Thanks for being with us. :slight_smile:

    Best Regards,

    Milan

  • Milan
    • WordPress Wizard

    Hello Kelley

    I am really sorry but I missed one important key point here on which I want your attention to move.

    Actually this is not a bug but our Directory plugin includes copy of CustomPress plugin. Basically Directory is one custom post type in CustomPress plugin. That’s why when you activate Directory plugin, CustomPress plugin is also gets automatically activated and then it initiates its custom post types.

    If you see CustomPress > Content Types, you’ll see custom post type with slug as directory_listing.

    So conclusion is that, its not the bug but this is how two plugins are connected with each other. :slight_smile:

    I am extermally sorry for inconvenience caused here. Hope you’ll forgive me. :slight_smile:

    Kind Regards,

    Milan

  • Kelley
    • New Recruit

    Ok that makes sense that its a custom post type in CustomPress – but I don't see the directory_listing content type on any of the tabs on that page. I can create a test-site to show you (I currently have it disabled).

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.