Directory plugin installation fails

Hi there,

I wasn't able to submit the ticket without choosing an installed plugin, which defeats the purpose of this query a bit. My issue is with the DIRECTORY plugin.

I'm trying to install the Directory plugin, but am getting an "Installation failed" message that asks me to check permissions.

All other installations have been successful, and I've tried it with permissions set to 775 and 777.

Thank you.

  • Rupok

    Hi Anna, hope you had a wonderful day.

    That's weird. I just installed Private Messaging and Directory plugin in my test site through our WPMU DEV Dashboard plugin without any problem.

    I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Moreover, Can you turn on debug mode in WordPress? To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    Past errors here. If file is very long, paste them to a text file and attach with your reply.

    Have a nice day. Cheers!
    Rupok

  • Nithin

    Hi Anna,

    Hope you are doing good today. :slight_smile:

    I could see only Directory plugin & Private messaging is not being installed, could you switch to a default WordPress theme, and disable all your other plugins except WPMU DEV. And then perform the Directory plugin installation only. Please check whether it makes any difference. If that didn't resolve, in you next reply, attach the debug.log file located in your /wp-content/ folder. Please do note that you attach the file in txt format.

    Please let us know how that goes. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Kasia Swiderska

    Hello Anna,

    Debug log didn't say more about nature of the issue - strange that only those two plugins are problematic and you can still install other from WPMU DEV without a problem. I would like to troubleshoot this more.
    Could you please send in the following via our secure contact form https://premium.wpmudev.org/contact/ :

    - Mark to my attention, the subject line should contain only: ATTN: Kasia Swiderska
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.