Directory plugin is allowing comments - how do I turn them off?

The directory plugin is pulling the default WP page. I want to be able to turn off comments at the bottom of a directory listing. Is this possible?

Thanks.

  • Vaughan
    • Support/SLS MockingJay

    hiya

    if you want to disable them permanently for listings

    goto dashboard > custompress > content types

    then edit the directory_listings content type.

    untick the supports comments checkbox and save (see screenshot)

    that will disable comments for all new listings.

    to remove from existing listings, you will need to edit each listing & resave. no need to change content, just click to edit the listing, then hit the update/publish button to resave the page. that should then remove the comments from the existing listings.

    hope this helps.

  • Parsons
    • Design Lord, Child of Thor

    @Vaughan:

    Unfortunately, I do not have access to edit the post type. I have a multisite installation and the plugin is only activated at the sub domain level. When you go to edit the settings (like your screenshot) it notes that you can only "Edit in Network Admin".

    Outside of network activating the plugin, is there another way to disable comments?

    Thanks.

  • Vaughan
    • Support/SLS MockingJay

    hiya

    you shouldn't install the custompress plugin seperately when using directory.

    if you network deactivate custompress, i think you should then be able to edit the content types on the subsite. directory comes with custompress, so once you activate directory on a subsite you will see custompress in the menu also.

    hope this helps.

  • Parsons
    • Design Lord, Child of Thor

    @Vaughan

    You note that "I think you should then be able to edit the content types on the subsite."

    Per my previous post, you can not do this and that is the issue: "I have a multisite installation and the plugin is only activated at the sub domain level. When you go to edit the settings (like your screenshot) it notes that you can only "Edit in Network Admin"."

    Any other ideas on how to get around this issue?

  • Vaughan
    • Support/SLS MockingJay

    hiya

    the image i posted was taken from my subsite & not the network dashboard. mine is also a multisite.

    do you have custompress installed and network activated? if so then network deactivate it, that's the only reason i can think of why you would get that message.

    i'm stumped on this. let me just ask the developer for some help on this.

    thanks

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.