Directory Plugin Theme – Still getting fatal error message ( for normal posts)

Just wanted to make sure that support knows that this important issue is not yet resolved for me.

https://premium.wpmudev.org/forums/topic/directory-plugin-normal-blog-posts?replies=19#post-212365

Thanks

PJ

  • PC
    • WPMU DEV Initiate

    Hey PJ,

    I am sure Joe would be on the other post real soon, I understand that its really urgent for you however, sometimes support might get busy on handling issues. I am sure someone would have a look at it real quick.

    Cheers

    PC

  • Kimberly
    • Champion of Loops

    PJ

    Seems you are experiencing the trouble with opening a new issue beneath an old ticket. It does tend to get buried.

    I’ve closed the other thread and Joe will know where to go :slight_smile:

    Posting your error for reference: Fatal error: Call to undefined function dp_posted_on() in /home/sfcoupon/public_html/wp-content/plugins/directory/themes/default/loops/loop-single.php on line 7

    Line 7 is:

    <?php dp_posted_on(); ?>

    This refers to the meta data in your post. Usually pulled from your post and blog settings. Do you have your settings in order in Dashboard>Settings>General?

    You can always try to comment out this line if you don’t care if it is there or not.

    Best,

    Kimberly

  • PJ
    • Design Lord, Child of Thor

    Regarding error at SF Coupons (link to error message page)

    Thanks for your response.

    As far as I could see in the forum this issue was still open.

    To answer your question, my settings are fine.

    This error happens whenever I try to view a post. I would like to be able to post / have regular blog posts on this website, in addition to directory listings. Therefore, wouldn’t it make sense to try to correct this code instead of just deleting it? Perhaps I misunderstand..

    Can you or someone else explain in some greater detail what might be wrong with this line of code, and how I can fix it, or experiment with different fix options?

    This refers to the meta data in your post.

    does not really tell me enough.

    This is getting very frustrating.

    ALSO, What is your favorite way to comment out a line? I am not php savvy.

    Thank you in advance

    PJ

  • PJ
    • Design Lord, Child of Thor

    Here is a PDF file for my loop-single.php.

    Below is the error message

    Fatal error: Call to undefined function dp_posted_on() in /home/sfcoupon/public_html/wp-content/plugins/directory/themes/default/loops/loop-single.php on line 7

    Actually, the site is not allowing me to attach / upload a file. So, here is part of the file, starting from the top of the file:

    <?php while ( have_posts() ) : the_post(); ?>

    <div id=”post-<?php the_ID(); ?>” <?php post_class(); ?>>

    <div class=”entry-meta”>

    <?php dp_posted_on(); ?>

    <?php do_action(‘sr_avg_rating’:wink:; ?>

    <span class=”comments”><?php comments_popup_link( __( ‘No Reviews »’, THEME_TEXT_DOMAIN ), __( ‘1 Review »’, THEME_TEXT_DOMAIN ), __( ‘% Reviews »’, THEME_TEXT_DOMAIN ) ); ?></span>

    <?php dp_posted_in(); ?>

    <?php edit_post_link( __( ‘Edit’, THEME_TEXT_DOMAIN ), ‘<span class=”edit-link”>’, ‘</span>’ ); ?>

    <span class=”tags”><?php the_tags( __( ‘Tags: ‘, THEME_TEXT_DOMAIN ), ‘, ‘, ”:wink:; ?></span>

    <?php if ( get_option( ‘comment_registration’ ) && !is_user_logged_in() ) : ?>

    <?php echo ‘<p class=”must-log-in”>’ . sprintf( __( ‘You must be logged in to rate item.’ ), wp_login_url( apply_filters( ‘the_permalink’, get_permalink( $post->ID ) ) ) ) . ‘</p>’; ?>

    <?php else: ?>

    <?php do_action(‘sr_rate_this’:wink:; ?>

    <?php endif; ?>

    </div>

    Hope this helps.

    PJ

  • PJ
    • Design Lord, Child of Thor

    Perhaps I am wrong about this, but is there someone who is primarily responsible for the Directory plugin theme?

    I am wondering why I am not getting any detail information about how to correct this fatal error message.

    The plugin does not result in a fatal error when other themes ( like Thesis or WordPress default themes) are activated; just when the default theme that comes with the plugin is activated.

    If this cannot be fixed now, I would like to know what is in the works, or if this project is going to disappear.

    Possibly one of the theme developers no longer works on this. And, the other theme designer has passion in design is color and layout

    This looks like some type of coding / programming error.

    I look forward to some help.

    Thanks

    PJ

  • PC
    • WPMU DEV Initiate

    Hey PJ,

    It seems more like a config error to me than a programming error. As had it been a bug, it would have been reported n number of times.

    I am doing some more research on it and should have something for you soon unless, Joe comes riding his ferrari and drops a pack of solution as always :slight_smile:

    Cheers

    PC

  • Kimberly
    • Champion of Loops

    PJ

    You are the only person reporting this error so we can be assured it is not a bug in the program.

    here is some great information on Post Meta Data and the term that your file is calling for

    http://codex.wordpress.org/Post_Meta_Data_Section

    We have recently gotten a new developer on board and he is helping with getting Directory up to speed. Sadly, like the rest of us he only has 10 fingers and 24 hours in one day so he is limited in how fast he can work :slight_smile:

    You can try replacing your /plugins/directory/themes/default/loops/loop-single.php file with the one I am attaching. Perhaps that will help.

    Have yout tested to see if this is a plugin error? With all plugins off except for directory?

    Best,

    Kimberly

  • PJ
    • Design Lord, Child of Thor

    It will not let me attach the file, I can mail you a fresh copy if you would like.

    Yes, please email me the file. thank you kindly.

    Regarding my being the only one reporting this error, I have to say:

    1) I believe I found at least one other person with same error message. see this link

    2) I have found very very few websites / WPMU Dev users who have installed and are still,using this Directory plugin. If I am wrong about this, please .show me examples.

    Thanks

    PJ

  • Kimberly
    • Champion of Loops

    I’ve mailed the file.

    If that doesn’t work then we should see about commenting out that line to see if it works. I can make the adjustments and mail again if the fresh copy doesn’t help.

    You are correct that very few of the folks here are using Directory (minus a few members who are doing some mega-customization). That is because Directory admittedly does not meet our standards for our plugins. The developer who created it is no longer with us and it has been reassigned to another developer who is working very hard to get it up to spec for us.

    There are problems that exist beyond the ones you see which means he is tacking a bigger issue than those that manage to get reported here, while trying to accomidate everyone who is using it. I can assure you he is working and aware of the state of the plugin (you don’t need my word, just search recent posts in the Directory forum).

    Hope this candid explanation helps to clarify a bit.

    As for your other user example of error, I agree that is the same issue. However we generally try to separate issues between releases as it can be any number of things causing the error even though it surfaces as the same error.

    Best,

    Kimberly

  • PC
    • WPMU DEV Initiate

    @pj, I hope Kim’s suggestion, as always, will lead you somewhere :slight_smile:

    @kim : I would have to get a visit to the ortho if I had to type that long a post. I will have to work more on my typing skills so as to take them to the next level

    Cheers

    PC

  • PJ
    • Design Lord, Child of Thor

    Thanks to Kimberly especially for the candid and detailed response about the status of the directory plugin.

    This level of detailed explanation is great, partly because it helps me know to how much time and energy I should commit to any sites of my that might really need a directory.

    Will try that replaced file. If and when I resolve this issue on my end, I will then mark the issue as resolved.

    Thanks

    PJ

  • PJ
    • Design Lord, Child of Thor

    RE: Normal Posts link.

    I replaced the file, and it still does not work. Here is a site

    Notes:

    1) Sometimes, on different installations, its says LINE 6. sometimes LINE 7. Not sure what this means, but perhaps helpful?

    2) So far I do not have other issues, other than NORMAL POSTS. so, one solutions is to set up the site without option to see NORMAL POSTS.

    3) I still have no problems with other themes, like thesis or the default wordpress theme; so the problem seems to be with the default directory theme

    Thanks

    PJ

  • aecnu
    • WP Unicorn

    Greetings PC,

    Thank you so much for taking notice. It is amazing how few people actually notice that the new support team is working far many more hours and times then are officially posted:

    Support staff hours are 9AM – 5PM CST (US) Monday – Friday… threads posted outside this time may experience response delays of 12 – 16 hours or longer at weekends.

    It is great that you have noticed.

    Cheers, Joe

  • PJ
    • Design Lord, Child of Thor

    Thank you for your response regarding the plugin directory.

    IMO, staff should consider some form of notice for people considering buying and/or using this plugin.

    I understanding that this plugin and directory are being worked on. However, I personally wasted 6+ hours trying to install this.

    PJ

  • aecnu
    • WP Unicorn

    Greetings PJ,

    Thank you for your feedback, it is greatly appreciated.

    staff should consider some form of notice for people considering buying and/or using this plugin.

    I understanding that this plugin and directory are being worked on. However, I personally wasted 6+ hours trying to install this.

    I am truly sorry that you had trouble with this plugin or any of our products for whatever the reason may be.

    I would love to be able to tell people about the Directory plugin (currently for medium to very skilled members only?), but how to put it is the problem since there are so many different skill levels and how to gauge them.

    There are many people whom have installed this plugin and we just had to figure out an image problem or other small item and they are having no trouble with the plugin at all or have the skill to fix it themselves and have done exactly that.

    Hopefully we will see the release of the directory plugin very soon and as I mentioned earlier I truly appreciate your feedback.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings PJ,

    The word is out on the status of the Directory plugin in which it has also been temporarily removed from WPMU Dev until the new release is out.

    The Beta is already out to limited participants and we anticipate a release soon.

    Thank you for your patience.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings PJ,

    The new release is out version 2.1

    It is such a large release that it is recommended that you delete Custom Press plugin if you ideed have it installed and anything else relative to the Directory plugin itself for a smooth transition.

    Thank you for being a WPMU Dev Member!

    Cheers, Joe

  • Kimberly
    • Champion of Loops

    Hi Gina!

    Sorry to hear you are having troubles! This ticket is a bit lengthy and we don’t want to get your issue confused with the original posters’ issue (as it was pre-the latest update and your setup is probably a bit different from his) so could I ask you to start a new ticket?

    https://premium.wpmudev.org/forums/tags/directory#question

    please be sure to include the relevant version information and any specific errors or issues you are seeing

    I want to make sure you get the best help :slight_smile:

    Thank You!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.