Disable Auto-Close on Popup's Thank You Message

I think I must be missing the setting somewhere in the UI, but I don't see it. I don't want the popup to autoclose after 5 seconds. How do I disable this?

  • Jason Robinson

    This appears to be controlled by lines 89-91 in /plugiins/hustle/assets/js/front/common/submit.js

    I would hope that the 3000 value could be controlled from the UI, and if set to blank/null/nothing, that section of code would not fire at all. I would modify the code myself, but it would get overwritten by the next update to Hustle. Anyone have any bright ideas about how to hook into that click binding to override is outside of the plugin?

  • Luís

    Hi Jason Robinson ,

    Hope you're doing well today!

    Firstly, sorry for the late reply and all the problems it may have caused.

    From what I know, this option is on the roadmap and it will be added in the upcoming releases, I can't provide an ETA or garantee that will be included in the next release, but, definetly is on the roadmap.

    This appears to be controlled by lines 89-91 in /plugins/hustle/assets/js/front/common/submit.js

    I tested changing this value on the file, but it didn't made any effect on the autoclose time, maybe we will need to change this in other place too. I already pinged the developer to get more information.

    Cheers, Luís