disable comments – gridmarket

Hey Guys. Perhaps I am missing something really obvious, but I can’t seem to get the comment form to go away on blog posts or pages. I swear that I have disabled them, but they still show up. I’ve also tried commenting out various parts of Framemarket’s templates to no avail. Anyone else have this issue?

I’m using WP3.1.3 (single), Market press and the Gridmarket child.

The work in progress is here

edit: check out one of the blog posts. same problem on any new pages as well.

  • MinFli
    • Design Lord, Child of Thor

    Hi dubya,

    Which post(s) have you disabled comments on?

    If you want to give me temp access, I can locate the issue in the page.php file and explain how to fix it. I won’t make any changes without your permission.

    If you “un-check” the checkbox and the comment box is still showing up… it is either an issue with the page.php file, index.php file, or functions.php

    Just let me know. Take care!

    Jim

  • dubya
    • The Incredible Code Injector

    Thanks @minfli

    I walked away from the problem for a while. When I had another look, I realized that new pages and posts created after disabling comments are fine. So, my solution is to recreate the pages & posts that I do not want comments on and then delete the originals. Weird. I’ve never turned comments off before, so I had no idea it would behave this way.

    Problem sorted.

  • Tammie
    • WordPress Wizard

    Have you by any chance a cache plugin installed – just thinking could be at play.

    Sometimes people do wish on all pages to remove comments this can be done by removing

    <?php comments_template( '', true ); ?>

    In content-page in FrameMarket.

  • TamahomeJenkins
    • New Recruit

    I have the same issue as dubya, and I don’t have any cache plugins installed. Having to recreate any pages that were created before you disabled the comments doesn’t seem like much of a resolution. It’s more of a workaround and a PITA if you have a boatload of pages on your site.

  • Tammie
    • WordPress Wizard

    This isn’t a theme issue a lot of themes either have on or off comments – we just in our themes usually have this functionality. If you want to turn off just copy that template into the child theme and remove the line I listed above.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.