Disable mandatory service provider selection

Hello,

I would like to disable the mandatory service provider selection so a client can search for a free timeslot and make an reservation.

Right now the client has to select a service/serviceprovider/timeslot. I would like to cut the serviceprovider out of that order and just show the available times for that service. How should I set this up?

  • Alexander

    Hi @Yardco,

    A service provider will always need to be selected, but you can use a shortcode to predefine this so the user doesn't need to make a selection.

    Just edit your "Make an appointment" page and add the "worker" attribute to the schedule shortcode like this:

    [app_schedule worker="3"]

    You'll need the service provider ID, which can be found in the leftmost column of the service providers tab of Appointments+ settings.

    Best regards,

  • Alexander

    @Yardco,

    So they would just book a time and get paired up with whoever is available? Sure, we can add as a feature request.

    For now, you can do something similar by creating a new Service Provider and enable it as a "dummy" This makes it a generic account. Then use the shortcode described above with the new providers ID. The notifications will go to the user you have setup to handle dummy accounts in the main Appointments+ settings

    Best regards,

  • pxwm

    Hi @Alexander Rohmann - I hope you don't mind me chiming in

    Hi @Yardco

    If I've understood your requirement correctly and you are happy to assign a Service Provider in the A+ back end then you could try the following:-

    Login to your Wordpress dashboard
    Select A+ Settings
    Select 'General' tab
    Scroll down to the 'Additional css Rules' field
    Then enter the following in a new line retaining any existing bespoke css code:-

    .app_workers {display: none;}

    Then Save

    This will 'hide' the 'Service Provider' dropdown box in the appointment page

    If you then try making an appointment it should show the 'Services' dropdown and selecting the 'Service' it should display the schedule as though the 'no specific provider' had been selected.

    You will notice in the booking form that it will NOT indicate the name of a Service Provider.
    However when the user confirms the appointment it will show the Service Provider name as 'Our Staff' in the appointment table.
    If you check in the A+ back end and click on the relevant appointment to show the details then it shows 'Our Staff' as the 'Service Provider' assigned to the appointment. You will need to allocate an available 'Service Provider' for the appointment so it blocks out the Date/Time of the appointment against a Service Provider.

    If this meets your requirements please let me know how you get on.

    Regards
    SteveB

  • Yardco

    @pxwm Thanks for your help here. I added the css rule but unfortunately doesnt solve the problem (or im doing something wrong).

    Currently i have set up 3 service providers with 2 services. 1 provider has a few dummy's lying underneath and 1 service selected, while the other 2 providers have the other service selected. Once i want to select the service with 2 providers, all my options are red and i have to use the "select service provider" box before i can select a time. The latter id like to avoid by just showing all available times for that particular service.

  • pxwm

    Hi @Yardco

    I've checked your settings and I would suggest there are a few that need revising and I've proposed a way forward.

    From your settings I'm making the assumption that you have 1 x 'real' Service Provider (PT2Day) and 9 x 'dummy' Service Providers all assigned to 'Service' - 'Small Group Training'

    You then have 2 x 'Service Providers' (Back 2 Basics 1 and Back 2 basics 2) assigned to one 'Service' - 'Back 2 Basics'.

    If I'm correct then could you try the following:-

    Service capacity settings
    'Small Group Training' - Can you set the Capacity to '0'
    'Back 2 Basics' - You currently have the Capacity set to '6' whereas you only have 2 x 'Service Providers assigned so the maximum appointments you can make for this Service for any given Date/Time will be two (2). I suggest you set the Capacity to '0'

    You have a screenshot of 'Service Provider' (Simone).

    I appreciate you state this is due to you making an appointment but if these are the 'Working Hours' for the 'real' Service Provider (PT2Day) then it appears that the 'Working Hours' are different to the 'dummy' Service providers and to confirm they need to be all the same for the 'Service' - 'Small Group Training'.

    Please Note: If you wish to 'hide the 'Service Provider' dropdown in the appointment page you will need to set the 'Working Hours' for the 'no specific provider' for the available hours for both 'Service'.

    You may wish to view my solution in the following post as they also required the 'Service Provider' dropdown to be hidden.

    https://premium.wpmudev.org/forums/topic/october-calendar-has-missing-appointment-days#post-522617

    It is quite a lengthy post but it does result in a working solution.

    As for:-

    I think i found a bug tho.. my main service providers name changes to a clients name when theyve made an appointment (thats why pt2day is simone in the last screen).

    This may have been due to you being signed in when you made the appointment.
    Could you try signing out and making an appointment to check if you still experience this problem.

    You may wish to refer tot he following post as they seem to have had the same problem:-

    https://premium.wpmudev.org/forums/topic/why-does-the-program-keep-saving-my-clients-name-as-the-provider-and-puts-my-name-as-client#post-522945

    I hope this helps
    Regards
    SteveB

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.