Disable "Pay" button in scheduled appointments view

When viewing the list of scheduled appointments for your account, there is a Pay button. How do I hide this? I can't find anywhere in the settings where to do this. We are not accepting payments, so that part is already turned off so this button does nothing on click.

  • Adam Czajczyk
    • Support Gorilla

    Hello Sara

    I hope you're well today!

    The button there would suggest that the service are set as paid and appointments were not paid during booking process. However, if you have disabled payments entirely, there must be some other reason and I'll need to pinpoint it.

    Would you please enable support access to the site so I could take a closer look? To do this go to the "WPMU DEV -> Support" page in your site's back-end and click on "Grant support access" button there.

    Let me know here once it's done, please, and I'll access the site and look for the cause and solution.

    Best regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Sara

    Thank you for enabling access!

    I checked the site and there are two ways to deal with it currently:

    1. Your appointments are not set to be automatically confirmed. If you set them to be autoconfirmed on "Appointments -> Settings -> Genberal -> Accessibility" page, there'll never be a "pending" status and no button.

    However, I understand that you might not want to have them automatically confirmed so in such case you can use following CSS as a workaround:

    input.appointments-paid-button {display:none;}

    Just add it to the "Appearance -> Customize -> Additional CSS" option in site's back-end or via theme's "custom css" option if there is such an option and it should hide it.

    It's also worth noting that such "pending" appointments (with the "pay" button) will only be shown if a "my_appointments" shortcode includes them like this

    [app_my_appointments status="paid,confirmed,pending"]

    With default shortcode that's currently used on site

    [app_my_appointments]

    those pending appointments are not even shown on site.

    To sum it up: if you do not want appointments to be automatically confirmed but do want pending appointments to be displayed on "My Appointments" list to the customer, add the aforementioned CSS to the site and adjust shortcode on "make an appointment" page.

    Finally, what I suggested above is a "working workaround" but it seems that we just discovered a bug in the plugin. I run a couple more testes on my own setup and it seems that if the "pending" appointment is displayed on a list, it always has the "pay" button displayed, regardless whether it's paid or not and if payments are entirely disabled or not. I've reported this to our developers already so they could look for a fix.

    If you have any additional questions on this, let me know please.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.