disable scroll in google map widget

I enabled "disable scroll" in addons and am able to disable scroll in map options and map shortcode BUT I also need to disable scroll in google map WIDGET. There is no setting to do that. Can you please advise how this can be done or perhaps share a piece of code I can add to my page that would prevent the scrolling. Map widget is an integral part of my website usability.

PS I can not use map shortcode instead of widget because even though I use exact same parameters in shortcode as in widget, for some reason map comes up blank for me with shortcode.

  • Dimitris
    • Support Star

    Hey there Polina,

    hope you're doing good and thanks for reaching us! :slight_smile:

    I can not use map shortcode instead of widget because even though I use exact same parameters in shortcode as in widget, for some reason map comes up blank for me with shortcode.

    This could be happening because shortcodes aren't being rendered in frontend. Could you please try to add next snippet inside functions.php file of your child theme?

    // Enable shortcodes in text widgets
    add_filter('widget_text','do_shortcode');

    Then try to add a map shortcode via a Text Widget the way you used this inside a page/post content.
    Reference: http://www.wpbeginner.com/wp-tutorials/how-to-use-shortcodes-in-your-wordpress-sidebar-widgets/

    If this has no effect for you, could you please use the note area in Network admin -> WPMUDEV -> Support to share with us the page in question?
    A URL should be enough for us.

    Warm regards,
    Dimitris

  • Polina
    • Flash Drive

    Hi,

    Thanks for getting back to me. Sorry, the answer does not really help with my situation. I actually want the map to appear inside a page not sidebar, but if I use shortcode the posts markers do not show up, but if I use the widget the posts markers do show up so for now I had to resort to using widgets in pages plugin to show your widget inside a page. If you can help me get the shortcode working then I do not really need the widget at all.

    Here is the map in widget that does work: http://www.vanuatuinterisland.com/map/

    And here I have setup a test page to show that the shortcode configured the same was as the widget does NOT work:
    http://www.vanuatuinterisland.com/test/
    [map query=”all” show_posts=”true” width=”100%” disable_scroll="true" overlay="true" zoom="14" height="500" width="500"]

    Attached is my widget configuration for comparison.

    I have already granted support access to my site in relation to another google map issue they are investigating on another site within my multisite installation. Here is the thread and you can get login credentials there: https://premium.wpmudev.org/forums/topic/google-maps-plugin-multiple-maps-auto-generated
    The main site of this multisite installation is invanuatu.net/wp-admin/

  • Polina
    • Flash Drive

    Hi,

    I changed the theme of the site so now I am definitely using the map widget and it is an integral part of my directory website so the scroll really needs to be disabled, its practically unusable with it on. Any tips? Maybe some javascript code or something?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.