Disable the file editor showing as alert when already disabled

Hi there , the hub is flagging 1 issue for this site which is Disable the file editor although when I click through to “view and fix this issue” it is already disabled.

  • Tyler Postle
    • CGO

    Hey Andrew,

    I just pinged for updates from your site, can you check the Hub again and see if it still is showing that 1 issue? If it is, can you upload a screenshot of that Hub tab?

    I’ve just tested this on my site and it updated both sides properly when I performed the hardening tasks.

    Look forward to hearing back :slight_smile:

    Cheers,

    Tyler

  • Tyler Postle
    • CGO

    Very strange, I'm wondering if your other security plugin is causing a conflict there. Or any of your other plugins for that matter, but I do suspect it would be the other security plugin.

    Can you do a full plugin conflict check just in-case? You can follow this flow chart:

    If the issue still persists, or if you would rather I do that conflict check for you then can you send in your FTP? Then we can troubleshoot further.

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    Send in:

    Subject: "Attn: Tyler Postle"

    -WordPress admin username

    -WordPress admin password

    -login url

    -FTP credentials (host/username/password)

    -link back to this thread for reference

    -any other relevant urls

    **If you keep support access active then no need to send in wp-admin

    Talk to you soon!

    Cheers,

    Tyler

  • Andrew Shutlar
    • WPMU DEV Initiate

    OK I switched to default theme and disabled all other plugins, the problem still persisted. I then reenabled all plugins and reenabled my theme and it was still persisting.

    I then thought to go to dashboard and “revert” the Disable the file editor then secure it again and the sync issue was resolved by doing this. I suspected this might resolve it but wanted to see what was causing the issue to avoid having to do this in the future.

    Thanks

  • Andrew Shutlar
    • WPMU DEV Initiate

    OK I have now moved onto my next domain name on the list and the exact same issue exists. Disable the file editor is showing as needing to be done when it is already done.

    This time I skipped straight to reverting back this setting and then enabling it again, this time when I clicked the red button to Disable the file editor it took clicking it 5 times for the item to be secured it kept coming back to the same screen saying i needed to secure it then it finally went green and the hub showed it as secure. it wasn’t until the 5th time that the hub showed it as resolved too.

  • Julian
    • Fake Russian Bot

    I have a similar issue, but with “upgrade WordPress to latest version”. When I check that hardening step, it shows the latest version available and the currently installed version, the currently installed version is blank and Defender thinks WordPress isn’t up-to-date. Drives me nuts!

    I opened a topic on this here.

  • Tyler Postle
    • CGO

    Okay, I’m back already :smiley:

    Andrew Shutlar would you mind sending in your FTP? Spoke with the developer and he suspects this is a network issue. We would like to investigate that a bit further by setting up a log inside Defender.

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    Send in:

    Subject: “Attn: Tyler Postle

    -WordPress admin username

    -WordPress admin password

    -login url

    -FTP credentials (host/username/password)

    -link back to this thread for reference

    -any other relevant urls

    **If you keep support access active then no need to send in wp-admin

    Look forward to hearing back.

    Cheers,

    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.