Display of CPU and memory usage

Hey guys,
Just following up on the features feedback from the initial hosting thread. Specifically I would love to hear about this on

- Server resource usage statistics for things like RAM, CPU, I/O (Julian)

I ask as I have a multisite setup on one of the droplets which was running relatively well UNTIL I activated the staging site for it and have been experiencing downtime almost daily since. It seems that it is running out of memory on many occasions.

Would be great if we could get a display of the memory usage to see how much is being used in order to accurately assess our options.

Thanks

  • Nithin
    • Support Wizard

    Hi Baldafrican,

    I ask as I have a multisite setup on one of the droplets which was running relatively well UNTIL I activated the staging site for it and have been experiencing downtime almost daily since. It seems that it is running out of memory on many occasions.

    Just to be sure, you are noticing out of memory error in both live, and staging? or in any one site specifically? I'm also checking this with our developers to see whether they could pin point the root cause regarding this.

    I do see that displaying memory limit usage stats, and other essentially details would be really helpful, and handy. I'll make sure to check this with our team, and see the possibilities to display such detailed info in the hosting page side.

    Will keep you updated once I get more feedback regarding these raised queries. Have a good day. :slight_smile:

    Regards,
    Nithin

    • Baldafrican
      • Made in Africa

      Hey Nithin ,
      Looking at the logs it displays it on the production site and is calling out the theme for using too much memory. That said, it may just be coincidence that it started after I activated the staging site. Have been trying to figure out how to deactivate it to test it but can't seem to find how to do so and live support seems very busy today.

      Any ideas?

  • Baldafrican
    • Made in Africa

    So I have had 7 outages in 7 days so far on the droplet in question. Perhaps the hosting setup still has a way to go before it can be used for production sites?

    I know James Farmer has said that your incsub site is running perfectly so just to clarify was it setup in the same way we have been using to set ours up in the hub or is it just running a similar stack on a different server size?

    • James Farmer
      • CEO (of WPMU DEV, honest)

      It's true, we have had a few 'beta' issues, including impacting incsub.com sotes, sorry guys... the good news (and the reason we are very grateful to everyone here) is they are all very fixable and straightforward fizes which this process is exactly the perfect place and time for.

      We won't be removing the beta tag / officially releasing the product until we believe it's ready of course.

      However, I would still (if only die to the really solid and operational backup setup) encourage everyone to try out non business critical sites on the service - then, after we've proven 100% uptime plus everything else for a significant period (and we let you know) to go ahead with more critical sites.

      We're very, very close!

  • Baldafrican
    • Made in Africa

    Thought I would just update this one.

    The site in question has had a 100% uptime over the last 30 days (woohoo!! :raised_hands: ) and is consistently loading at around 2.8s (woo who? :confused: )

    Since the issue was the uptime, I think we can mark this resolved :muscle:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.