Displaying Slide In ONLY on certain posts

Hello,

I'm trying to achieve only having a slide in appear on certain posts.

I have a Slide in with setting "This is a post-specific slide-in" checked and I only have 1 post where I have selected it as the slide in, but it is showing up everywhere.

How can I get it to only show on the posts that I assign it to?

Thanks,
Jesse

  • Michael Bissett
    • Recruit

    Hey @Jesse, Michael here! :slight_smile:

    Is this happening on the main site in your network, or is it happening on a subsite? What kind of Multisite network do you have presently, would it be a subdomain, or a subfolder Multisite?

    And could you enable Support Access to it, and mention the post you've attached the slide in to?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please advise,
    Michael

  • Jesse
    • Site Builder, Child of Zeus

    Hi Michael, thanks for the quick response!

    It is on the main site in multi-site. I have a subfolder /store, but the plugin is not activated on that site, only the main site.

    Support access has been enabled.

    Thanks,
    Jesse

  • Michael Bissett
    • Recruit

    Hey @Jesse,

    It looks like the slide was cached by WP Engine's caching system, that would explain why you were seeing the slide in more places than it should've been.

    After clearing their cache, I'm no longer seeing it show up where it's not supposed to, can you confirm the same on your end please? Long term, it'd be something that I'd want to ask WP Engine about adding an exception for in their caching system, if possible. :slight_smile:

    Please advise,
    Michael

  • Jesse
    • Site Builder, Child of Zeus

    Thanks Michael, yes, their caching causes lots of issues. Thanks for identifying that!

    What specifically do I need to ask them to exclude from caching to make sure this and all future Slide Ins I create do not appear on all pages?

    Thanks,
    Jesse

  • Michael Bissett
    • Recruit

    Hey @Jesse,

    I'm not certain as to how their exclusion system works presently, but depending on how it works:

    - If they can exclude post types, try excluding the "slide_in" post type
    - If that's not an option, but it can look at post meta, the "wdsi_message_id" key would be something else to try

    However, as I thought on this further, it's possible that their caching system cached your slide in right after it was created, so you may just be able to cache after creating a slide, and thus prevent it from showing up everywhere (unless it's designed to be displayed everywhere).

    Kind Regards,
    Michael

  • Jesse
    • Site Builder, Child of Zeus

    Hi Michael,

    I checked with WP Engine on this and they did some trouble shooting. They said that it isn't caching related because when logged in with caching disabled, it still exhibits the behavior of showing one of the Slide Ins on all pages.

    I'm experiencing the same issue and clearing the cache doesn't appear to help.

    Any other ideas?

    Thanks,
    Jesse

  • Michael Bissett
    • Recruit

    Hey @Jesse, thanks for your patience here, hope you had a great weekend! :slight_smile:

    That's odd, I was able to get things so that the slide wasn't showing on all pages... hmm.

    I think it'd be wise if we had a deeper look at things here, could you please send in the following via our secure contact form:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress network admin access details (login address, username & password)
    - Include SFTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    On the contact form (linked to below), please select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thanks in advance! :slight_smile:

    Kind Regards,
    Michael

  • Michael Bissett
    • Recruit

    Hey @Jesse,

    After looking around on your staging site, I'm still not seeing a slide show up on more posts than what it's been assigned to display on. I do see that there's a popup on your site with a similar message, but no slide.

    (I tested with your "Are You Tired Of Choking On The Court?" slide)

    If you're still seeing it show up on more than just that one page, could you record a screencast of what's happening here? I'm a bit puzzled as to why it's doing this for you, yet it's working just fine on my end.

    You could use a tool like this to record a screencast:

    https://www.techsmith.com/jing.html

    Please advise,
    Michael

  • Michael Bissett
    • Recruit

    Hey @Jesse, no problem, thanks in return for your patience here! :slight_smile:

    I see what you mean here, and even when I try clearing & disabling the cache on the live site, I'm still seeing this occur on your site. However, I'm presently unable to replicate this over on my own test site.

    I tried looking over on your test site, but the WP Admin credentials you sent in before aren't valid anymore, could you re-instate those please?

    Kind Regards,
    Michael

  • Michael Bissett
    • Recruit

    Hey @Jesse,

    It looks like the staging site is at an older stage than the live site is, as I'm not seeing the post you brought up in your video earlier.

    The odd thing is though, I'm still not seeing a slide showing up on a page that it's not supposed to, would it be possible to sync the live site over to the staging site at all? Or, would it be possible to send in the WP admin & FTP access details for the live site?

    It seems like the live site is the place to look now, seeing as that's the only place presently where I'm able to run into the issue.

    Please advise,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.