DNS help on wpmudev hosting.

I am trying to set up a custom URL to serve my images from using the Offload Media to S3 plugin. They offer this guide …

https://de*******ains.com/wp-offload-media/doc/cloudflare-setup/

which says you need to add a cname pointing to your domain and add the aws part to the end. For example:

cdn.de+++++++loads.com.s3-eu-++++++-2.am+++++++.com

But when I add this cname in Cloudflare how do I add it into my wpmudev hosting panel as I am not sure if it will install the appropriate SSL cert.

I have tried but it provides an X under DNS status. Please check and help on this case.

  • Adam Czajczyk
    • Support Gorilla

    Hello Baldafrican

    I hope you’re well today and thank you for your question!

    You can’t add any new records (including CNAME) to WPMU DEV Host and you shouldn’t have to, actually.

    The CNAME type of DNS record is basically a kind of “alias” (well, it’s not exactly an alias but calling it that way explains fairly well what it does) and according to the docs that you already shared you need to create CNAME at CloudFlare.

    The issue with SSL however – that’s a bit different. You’d need to first make sure that you do have CloudFlare and the domain on WPMU DEV Hosting set properly to use SSL. With CloudFlare everything is about the “Flexible”/”Full” and “Full (strict)” settings. So, the first step to take care of would be to make sure about that.

    Let’s say your site is under “domain.com”. This domain has to be added to your WPMU DEV host. Since you’re directing it via CloudFlare you’ll first need to set CF SSL mode to Flexible or Full (you might need to experiment with that as it sometimes behaves a bit unexpectedly) but not “Full (strict)”. With “Full (strict)” setting our hosting will not be able to generate proper certificate on our end.

    If you set CF SSL to “Flexible” and the cert gets created on our end, you might then set that mode to “Full” or “Full (strict)” after that and the site should work fine over SSL. If you can confirm that then only after that you’d want to move on to offload configuration.

    So, moving on with this, you need to know your S3 region and bucket name. Next you create a new CNAME recrod in CloudFlare, not on the WPMU DEV host as described in that article from Delicious Brains and follow their guide down the road. The “HTTPS” section from the article can be skipped since you already have the working SSL-protected domain.

    Best regards,

    Adam

    • Baldafrican
      • Made in Africa

      Hey Adam Czajczyk

      First let me say I truly appreciate you taking the time and exercising patience when replying to my tickets. I am of the belief of instead of fixing issues, teach somebody how to do it and you will be bothered less. :slight_smile:

      In this case, I already have the website setup with a CNAME running through Cloudflare on a Full Strict SSL. This works great!

      Now I am looking at moving my media over to S3 which requires the steps that were detailed in the docs that I supplied.

      If I understand you correctly, and please feel free to correct me if I don’t, I should set the SSL to flexible and recreate the domain to issue a new cert? Thereafter, change it back to Full?

      When setting the CNAME in Cloudflare do I use the site name or the wpmudev server name when setting the region and bucket name?

      Thanks again

      • Baldafrican
        • Made in Africa

        So just to send through an update – I have tried the above according to my understanding but sadly it is still not working.

        When I switch over to a flexible SSL the website does not load anymore. I waited 24 hours but still nothing. Change it back to Full (strict) and the website loads but the bucket cannot be found. Even though when I upload an item through Add Media I can see it loads into the correct bucket on S3 but I just cannot view it if I place the url of the image in the browser.

  • Adam Czajczyk
    • Support Gorilla

    Hello Baldafrican

    When I switch over to a flexible SSL the website does not load anymore. I waited 24 hours but still nothing. Change it back to Full (strict) and the website loads

    Yes, that’s a bit tricky but it’s “kind of” expected. The point it that “Flexible” setting is only for the SSL generation time on WPMU DEV host. Once it’s generated and setup, it should be set to “Full (strict)” back.

    I’m not sure about that S3 bucket issue though. You say that when you upload item via “Add Media” it goes to the correct S3 bucket so what exactly does it return when you try to access the image – do you see any error on screen or at least in browser console? Does the same happen if you actually include e.g. image on site in page or post?

    Let me know, please.

    Best regards,

    Adam

    • Baldafrican
      • Made in Africa

      Oh, I forgot to include that by switching over what I did was;

      Change over to Flexible SSL

      Remove domain in the hosting panel

      Added the domain again

      Changed the SSL back to Full(Strict)

      And it did not work. Maybe it just does not like me :wink:

      Anyways I am going to shelve this idea as it is taking too long to get working and I have to attend to other projects. Thanks for the advice that you provided Adam Czajczyk perhaps I will try and work on it again someday.

  • Adam Czajczyk
    • Support Gorilla

    Hi Baldafrican

    Thanks for letting me know. When you decide to give it another shot, please update me here as well. We’re still in beta with Hosting but we’re heading towards going live and there are still various “configuration procedures details” being worked on so we might be able to help you better soon too :slight_smile:

    Have a nice day!

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.