Do I change Cname or A record when using Domain Mapping with a subdirectory install of Multisite

Psek installed my WP multisite in subdirectory configuration,(i.e., thriveonlinedesign.com/newsite) not subdomain. They claimed they could not set it to subdomains, but pointed me to directions that did not apply, leaving me baffled.

But I read that domain mapping should still work with subdirectories.

First, is that true?

If it is, my next question is about what to change re: DNS records.
The guidance/instructions on this site for directing a domain to a site on my multisite are all for subdomain (newsite.thriveonlinedesign,com.)

Should I be changing the A record or the Cname to have thethrivealliance.com point to thriveonlinedesign.com/test?

  • Timothy Bowers

    Hey there.

    I have no idea why they couldn't provide subdomain.... Odd.

    Domain Mapping does work with sub folders (Multi Domains - A different plugin, doesn't)

    CNAME is a Canonical Name, you could use that for mapping subdomains to a site within your multisite.

    A Records require you to have a dedicated IP which much resolve to your WordPress install so that all traffic coming in will be seen by WordPress and our plugin so that it maybe mapped correctly.

    In cPanel you can also use addon and parked domains because they allow you to define the DocumentRoot (path to your WordPress site). Pleask will also have something similar.

    Using the parked/addon option isn't practical if your doing this for clients, because it would mean you require access to control their domains DNS. Some might be ok with that but I personally wouldn't if it were me.

    Hope this helps.

    Take care.

  • imacg

    Hi Timothy,

    I could use some help with Domain Mapping. I am mapping a client subdomain in to a server and using CNAME to do that, with the CNAME set at our tld, then using domain mapping plugin to do the mapping - to a multi site set-up one level down in a subfolder install.. e.g. http://www.ourdomain.com/marketing and CNAME set to http://www.ourdomain for the clinet subdomain we want to map in.

    I have this working on one server fine and for example offers.clientdomain,com/marketing takes us to the correct site within the multisite set-up.. I f I had this runnign on a multi at the top level I wouldn't need the /marketing at the end, but that is fine as is.

    The issue I have is with another server where I cannot get the subs to map in. I'm trying to figure this out with my server comapny - i.e. what is different between these two.

    They keep telling me I need to park the domains but I explain that I cannot park clent tlds as they are in use, and that this works fine on one server so should work on the other.

    I know we have a dedicated ip on the one that works so I am asking them to check that on the non working one.

    Any inputs on this would be appreciated. What is also curios is that it did work for a while on the 2nd server and I had a client advertising campaign ready to go then it stopped resolving and would not map in again.

    I wonder if anyone else has seen anything similar and hopefully this might help others too.

    To recap, I am mapping a client subdomain into a subfolder multisite, one level down on my domain, using CNAME and the domain mapping plugin. It works fine on one server but not another, and I wonder if this is a dedicated ip issue.

  • imacg

    Hi again on this,

    while waiting for my server guys to get back to me, I tried mapping a sub-domain in using an A record - e.g. sub.clientsite.com mapped to my http://www.site.com and using the domain ip address. Last throw of the dice almost.

    It mapped fine and actually works...I tried this several times from several test domains, and using an A record maps the test subdomain in fine to the subdirectory install, whereas the CNAME method did not.

    The server guys got back to verify that these servers were shared and did not have a dedicated ip - so that was why it worked for me on one (with dedicated ip) and not the others.

    We are going to put a dedicated ip on the server and test the CNAME method again (as we don't want to go back to the client and get them to change their record again),

    I will advise later on results. For now, I can get this working using an A record, which seems to conflict with the plugin set-up advice..

    cheers,

  • Vaughan

    Hi @imacg,

    Please be aware you have replied to a thread that is over 2 years old. These old threads might not be monitored by staff, especially if it was from a staff member that no longer works here. It is recommended that you start a new thread, as different server configs & the age of the thread could mean the original solutions are no longer relevant, it also stops the original poster receiving email notifications that aren't related to their post.

    Thanks for your understanding.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.