Do I have to worry about plug in security if I am a WPDU member?

I got this from Elegant Themes Blog but it seems to me that my Dashboard/Defender handles this for me and I don't need to buy anything else. Is that true?
Thanks.

https://www.elegantthemes.com/blog/tips-tricks/about-wordpress-plugin-vulnerabilities-and-how-to-address-them?utm_source=Elegant+Themes&utm_campaign=34c948ff67-WordPress_Daily&utm_medium=email&utm_term=0_c886a2fc0a-34c948ff67-50254629