Do not have sufficient permissions

wp 3.3.1 multisite Buddypress 1.5.4., Theme: Buddypress Fun

Buddypress active on sub-blog

Buddy press is partially working. Signing up, profiles, activity streams. I am now trying to set up group forums and get the “You do not have sufficient permissions”. I am logged in as super admin.

Buddypress settings:

A. Components: all selected

B. Pages: All mapped

C. Settings: Cannot save the last setting option: Restrict group creation to site admins. Either choice will not save. All other items on settings page is showing as saved.

D. Forum: When trying to select install Group Forum – I got the “You don’t have sufficient Permissions” I then installed and activated bbPress, selected settings and then went back to Buddy Press and tried the Install existing forum – but got the same “You don’t have sufficient Permissions.

  • Timothy
    • Chief Pigeon

    Hey antKat.

    Can I please check, does this happen with all other plugins disabled? Including any Network plugins and MU plugins if in network mode.

    Also how does it work in the default Twenty Eleven theme, as themes can also affect the back end.

    Please let me know how you get on.

    Tim.

  • antKat
    • HummingBird

    Hi Tim,

    I deactivated all plugins except buddypress and changed theme to default buddypress this morning and still had the same problem. At the time, I did not deactivate mu-plugins. The only mu-plugin is si-captcha-for-wordpress.

    Since this is a live site, I can only close down during early, early morning.

  • aecnu
    • WP Unicorn

    Greetings antKat,

    Just checking if this issue was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that’s great news.

    If not, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the ‘Mark as Not Resolved (re-open)’ box below the post area (or else we’ll miss it!)

    Otherwise, happy days, glad you got it sorted :slight_smile:

    Thank you for being a WPMU Dev member!

    Cheers, Joe

  • bel
    • Flash Drive

    Hi,

    Reading the first post of @foodfrienfinder here, it seems to be a bug of BuddyPress.

    In my case, I’ve seen that I couldn’t run BuddPress Just in a subsite without activating it in the main multisite : I got the same error message.

    BuddyPress seems to need activation in the network in multisite configuration, for working fine.

    Thanks.

  • Timothy
    • Chief Pigeon

    Yeah, BuddyPress does indeed get network activated and by default appears on the main blog only.

    You can change this:

    define ( 'BP_ROOT_BLOG', 2 );

    Change the number to the ID of which ever blog you want it one. It will then work from that blog. Still the same data and all though.

    Take care.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.