Does Classifieds Plugin Work on LocalHost Dev Site?

I've set up the Classifieds plugins on a client localhost dev site and have found that the "Add New" function doesn't work.

After logging in as a user with Classifieds privileges and sufficient credits, I press the Add New button. Instead of being presented with an edit screen, the screen only refreshes. No errors, but no ad edit screen either.

I'm running the Genesis theme framework and a Genesis child theme on the DesktopServer localhost development platform..

Should the Classifieds plugin be able to run on a localhost development platform? (Other WPMU plugins work fine.)

Any idea why I'm not able to place a classified ad using the plugin?

Thanks for your help.

Bob

  • Bob

    Vaughan,

    I am not receiving any errors. The page just refreshes and shows "No Classifieds found." (See screenshot that I've attached.)

    There are no error logs in any of the folders you suggested.

    I'm already using "post-name" as my custom permalink.

    I haven't tried switching to the 2012 theme yet.

    I have, however, uploaded my localhost installation to a live demo subdomain. After doing so, the plugin is doing the same thing; it doesn't bring me to any sort of edit screen.

    When I inspect the "Create New Classified" button, I see that I should be redirected to an "add-classified" page as follows; <button class="cf_button create-new-btn add_classified_btn" type="button" onclick="window.location.href='http://demo.beniciaheraldonline.com/classifieds/add-classified/';">Create New Classified</button>

    When I check published pages, I do not see any pages named "add-classified". The only plugin-related pages are; "Classifieds" and two child pages called, "My Classifieds" and "Classifieds Checkout".

    You can view the demo site installation at demo.beniciaheraldonline.com.

    Any ideas?

    Bob

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.