Does Defender deactivate "Add Plugins" ?

Today I added the core WPMUDEV plugins so that I could do client reports.

And when I checked the sites I could no longer add plugins?

Does one of the plugins deactivate "add plugins"?

I'm thinking Defender Pro maybe? If so, how do I get it back?

TIA

  • Adam Czajczyk

    Hello SUP

    I hope you're well today and thank you for your question!

    Nor Defender neither any other of our plugins should do this on purpose. If it does that indeed, that would mean that there's some sort of conflict that's causing the site to malfunction. If you're suspecting Defender, the simplest test would be to temporarily deactivate it and the option should get back.

    However, even in that case I would expect that to be a conflict so I'd suggest starting with a full conflict test as described on this flowchart here:

    https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif

    Perform the test please and let me know about results.

    I noticed that you posted this in Members forum. Therefore, please note that this thread is not considered a support ticket. If you want me to move it to our support forum instead, let me know please and I'll do it for you.

    Best regards,
    Adam

  • Fetseun

    Hey Adam,

    I just got off the phone with my hosting and they said it was Defender Pro that was doing it. And they managed to rectify it via htaccess.

    So hence my presumption that it was a feature, not a conflict. But its happened to all my sites now and I am not sure what my hosting company did to to rectify it.

    Having said that, I have deactivated all my plugins and the problem persists.

    Could you please move it to support form, so I can try to figure out whats going on.

    Thanks

  • Adam Czajczyk

    Hello SUP

    Thank you for your response!

    I have moved the thread to the support forum so from now on it's a support ticket.

    As for the issue. It's not a feature, Defender is not supposed to do this on purpose so if it is causing it it must be related to some additional aspects. That may be a conflict, may be a bug that only shows up under certain circumstances, may be some specifics of the configuration that we are not aware of and that are interfering. We'll need to investigate it in order to find out why this is happening and how to fix/prevent this.

    That said, could you please ask your host what exactly did they do (what changes in .htaccess, how they determined it's Defender) and let me know about it?

    I would also need a full access to the site (because WPMU DEV support access is too limited in this case) so could you please send in:

    Subject: "Attn: Adam Czajczyk"

    - Mark to my attention, the subject line should contain only: ATTN: Adam Czajczyk
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - login URL and admin account login credentials (may be a temporary admin account) data
    - Include FTP log-in details (hostname, username & password)
    - Include hosting control panel access details (login address, username & password) - cPanel's usually the control panel used for this, but your provider may use something else; I'll need this for accessing your site's database, preferably via phpMyAdmin
    - Include any relevant URLs for your site

    Please use our contact form here https://premium.wpmudev.org/contact/#i-have-a-different-question

    I'll investigate the issue in order to find a cause and a solution.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.