Does e-newsletter work with WP 3.5.1

I know I should not still be using WP 3.5.1 but, for now, can you tell me if e-newsletter will work with this WP version?

kind regards,
Mark