Does the BETA Sync work at all?

I have setup the Appoinments+ plugin using the BETA sync option, and I am getting this error:

fatal error: Uncaught exception 'Google_AuthException' with message 'Error refreshing the OAuth2 token, message: '{ "error" : "invalid_grant" }'' in [SERVER PATH]/wp-content/plugins/appointments/includes/gcal/auth/Google_OAuth2.php:280 Stack trace: #0 [SERVER PATH]/wp-content/plugins/appointments/includes/gcal/auth/Google_OAuth2.php(257): Google_OAuth2->refreshTokenRequest(Array) #1 [SERVER PATH]/wp-content/plugins/appointments/includes/gcal/auth/Google_OAuth2.php(210): Google_OAuth2->refreshTokenWithAssertion() #2 [SERVER PATH]/wp-content/plugins/appointments/includes/gcal/service/Google_ServiceResource.php(167): Google_OAuth2->sign(Object(Google_HttpRequest)) #3 [SERVER PATH]/wp-content/plugins/appointments/includes/gcal/contrib/Google_CalendarService.php(569): Google_ServiceResource->__call('list', Array) #4 [SERVER PATH]/wp-content/plugins in [SERVER PATH]/wp-content/plugins/appointments/includes/gcal/auth/Google_OAuth2.php on line 280

Also when I test connection I get this:

Warning: Cannot modify header information - headers already sent by (output started at [SERVER PATH]/wp-admin/includes/template.php:1642) in [SERVER PATH]/wp-includes/pluggable.php on line 876

It is setup completely correctly, as I have worked with google apis before and knew exactly what to put in each field. How can I fix this?

  • Timothy Bowers

    Hey there.

    I got some fatal errors like this when I was setting it up, it was due to having incorrect settings.

    '{ "error" : "invalid_grant" }'

    For example:

    https://groups.google.com/forum/?fromgroups=#!topic/google-analytics-data-export-api/4uNaJtquxCs

    You're probably using the incorrect email there and need to grant full permissions. This is an advanced feature and it took me a little while to get it right myself. I do think this could maybe do with a tutorial that includes screenshots which should happen when it comes out of beta if people continue to have issues.

    If you could go over the instructions again and just ensure you copies the right items from the correct location for use on your settings pages.

    Let me know how you get on and if you're still having issues.

    Take care.

  • Hakan

    Hi,

    This message may be the key to the issue as it should not be there:

    Warning: Cannot modify header information - headers already sent by (output started at [SERVER PATH]/wp-admin/includes/template.php:1642) in [SERVER PATH]/wp-includes/pluggable.php on line 876

    Please try with the default theme and after all plugins are deactivated and share the results with us.

    Regarding the main question "Does the BETA Sync work at all". Yes it works for me and several other people who tested this several times.

    But we don't guarantee at the moment that it works in every installation, in every server, and in every theme. That is why it is BETA.

    Cheers,
    Hakan

  • Kimberly

    Hi!

    Just checking in :slight_smile:

    I'm guessing that because we haven't heard back from you that you've got your issue worked out via live chat or email, or that we have reached the end of our convo here. If you are still having problems or need any other answers on this particular topic please feel free to come back to this thread at anytime. Just be sure to mark it Not Resolved so we don't miss it! Or you can open a new one if you have a new issue.

    This ticket is only being Resolved due to lack of activity. It is by no means an action to avoid, brush off or minimize your issue. We are ready and here if you want to re-open at any time and I apologise any lack of communication if this ticket is being closed in error.

    Thanks for being part of the WPMU DEV Community!

    Best,
    Kimberly

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.