Doesn't work!

Click "main" for all widgets and press save. Setting reverts to "all" for all widgets. Cannot set it main.