Doesn't work with caching

Hi,

Had a look through the threads and all similar ones are dead ended, did anyone get anywhere with adding the 500 error header to the spam block notice page? We’re caching with Varnish and if a spammer hits the page it takes it down and shows all non-logged in users the “Access has been blocked” page. Had to disable 3rd party checking for now.

Cheers,

Ed

Edit: Adding the following to comment-spam-pack/avh-files/class/avh-fdas.public.php on line 639 should work in theory.

header('Spammer', true, 500);

Just before:

wp_die( $m );