Domain Mapping

I have and addon domain mobiyes.mobi that I installed this on. But when I click on any sites in the mobiyes.mobi multisite install it takes me to the main domain on the cpanel account fanpage4me.com..

What I was origanly trying to do is point m. subdomains to my multisite install where I am building mobile sites but same thing when you type in the m. subdomain it resolves to fanpage4me.com instead of the mobiyes.mobi addon domain on that cpanel so thought this plugin would do the job.. Any help

  • Timothy
    • Chief Pigeon

    Hey there.

    If your WordPress multisite is setup you can park or use addon domains in cPanel.

    You have to ensure they fall upon your WordPress site, i.e. when you load them you see your WP site first.

    Then you go to the subsites admin area and add the domain in there, it will then resolve to the actually site intended.

    If you wish to use A Records, then you would need a dedicated IP.

    When I load mobiyes.mobi it’s different to fanpage4me.com which you described in your first paragraph.

    Hope this helps.

    Take care.

  • scott74
    • The Crimson Coder

    I have one cpanel with a client domain of http://campbellairsecurity.com I created a subdomain there of m.campbellairsecurity.com and pointed it using CNAME of http://campbellairsecurity.mobiyes.mobi

    But that is resolving to http://fanpage4me.com which is the main domain on the cpanel where the mobiyes.mobi resides :slight_smile:

    So when I tried using Domain Mapping Plugin to fix this http://campbellairsecurity.mobiyes.mobi then also started going to fanpage4me.com

    I turned domain mapping off for now

    Hope that explains the problem better…

    Not sure what you meant about parking what where?

  • scott74
    • The Crimson Coder

    This is what I got back from Host Gator but Not sure how to configure WordPress to recognize like they suggest

    We have received your request and I understand that you are having a problem with your CNAME record m.campbellairsecurity.com. The CNAME itself on gator1359 is properly configured and working.

    The actual problem is an artifact of the configuration on your other account on gator1691. The subdomain campbellairsecurity.mobiyes.mobi isn’t configured explicitly, but the wildcard subdomain matches and returns your dedicated IP address.

    Since the domain m.campbellairsecurity.com isn’t configured on gator1691 WordPress is reverting to the default domain, fanpage4.me.

    In order for this setup to work you will need to configure WordPress to recognize the domain m.campbellairsecurity.com and return the same content as campbellairsecurity.mobiyes.mobi.

    If you are ok with the domain name changing in the browser you could use forwarding on gator1359 instead of a CNAME.

  • Timothy
    • Chief Pigeon

    Not sure what you meant about parking what where?

    Just terms, they are both similar.

    Parking – This parks the domain on a specific spot, just like parking a car really. You could then send a domain to another if you wished.

    Addon – This creates a folder or points to a specific folder for a new site.

    Can Is see screen shots of the CNAME please?

    Thanks.

  • Timothy
    • Chief Pigeon

    Looking at what Hostgator sent you, it seems that they are saying WP isn’t picking it up.

    In order for this setup to work you will need to configure WordPress to recognize the domain m.campbellairsecurity.com and return the same content as campbellairsecurity.mobiyes.mobi.

    Silly question but did you add this to the domain mapping plugin from the admin there?

    Let me know.

  • scott74
    • The Crimson Coder

    added the domain mapping plugin on the multisite where I am building the mobile. I think they took extra steps more than needed. Been emailing them back and forth but the problem is still not fixed.

    I thought you would just create a subdomain of m.campbellairsecurity.com then create a CNAME for it pointing to campbellairsecurity.mobiyes.mobi and everything should be fine but when you go to m.campbellairsecurity.com it continues to forward to fanpage4me.com the main domain on the mobiyes.mobi cpanel

  • scott74
    • The Crimson Coder

    added the domain mapping plugin on the multisite where I am building the mobile. I think they took extra steps more than needed. Been emailing them back and forth but the problem is still not fixed.

    I thought you would just create a subdomain of m.campbellairsecurity.com then create a CNAME for it pointing to campbellairsecurity.mobiyes.mobi and everything should be fine but when you go to m.campbellairsecurity.com it continues to forward to fanpage4me.com the main domain on the mobiyes.mobi cpanel

  • Timothy
    • Chief Pigeon

    I thought you would just create a subdomain of m.campbellairsecurity.com then create a CNAME for it pointing to campbellairsecurity.mobiyes.mobi and everything should be fine but when you go to m.campbellairsecurity.com it continues to forward to fanpage4me.com the main domain on the mobiyes.mobi cpanel

    You still need to add it in:

    Admin (of the site in question) –> Tools –> Domain Mapping

    Then add the domain or sub domain there.

    Was that not done then?

    Thanks.

  • scott74
    • The Crimson Coder

    Yes but when I use the domain mapping plugin, when you try to go to m.campbellairsecurity.com or even the direct link to the site campbellairsecurity.mobiyes.mobi

    It takes you to fanpage4me.com the main domain on the cpanel so I turned it off

    So yes i tried adding m.campbellairsecurity.com to the tools domainmapping field of

    campbellairsecurity.mobiyes.mobi

  • Timothy
    • Chief Pigeon

    Usually when I set these sorts of things up I would have different cPanel accounts on one of my servers.

    These are two separate installs right?

    When the domain is not mapped it still goes to that other domain, so it must be going into the IP or something, it’s not hitting your install to map it. This seems like the behaviour.

    Take care.

  • scott74
    • The Crimson Coder

    Correct, even when not mapped using the domain mapping plugin it hits the wrong domain.

    When the domain mapping plugin is on, the actual site url where the site is built then hits the wrong domain also.

    Yes, m.campbellairsecurity.com is on one server and I am trying to point it to another server where I am building the mobile sites. but the end destination is an addon domain of that cpanel.

    Only thing that worked was adding a redirection code to the fanpage4me.com htaccess file like this

    RewriteCond %{HTTP_HOST} ^m.campbellairsecurity.com$ [NC]
    RewriteRule (.*) "http://campbellairsecurity.mobiyes.mobi" [R=301,L]

    But it would not keep the custom cname m.campbellair url becuase it was a redirect and I would have to add every site in the htaccess to do so which defeats the purpose when you have a script to redirect when detecting mobile browser on the main site anyway

  • aecnu
    • WP Unicorn

    Greetings scott74,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.