Domain Mapping

Hi Guys,

Ive gone through your multisite tutorial, domain mapping and cannot configure ti to work. Not sure what Im doing wrong..

Using siteground Growbig.
Setup an A record using simple dns zone editor
– defilms.davidedwards.com.au
– mapped to ip 37.60.246.49

Id like it to map to http://www.defilms.com.au

I noticed I needed to setup a parked domain in order to get my emails working using defilms.com.au as the url.

I did get it to map when the parked domain was setup, however it was referencing the site prior to any content being created on the pages even though the content had been developed using divi layouts. it works when viewing the defilms.davidedwards.com.au url but no the defilms.. url.

Using sitegrounds' cPanel, do I need to setup a parked domain, sub domain in order to get domain mapping to work?

Let me know if Ive missed something. would love to get it working.

  • Adam Czajczyk

    Hi David Edwards

    I hope you're well today!

    When I'm visiting defilms.david...au I'm immediately redirected to the defilms.com.au, where some site (definitely made with Divi) loads, though there's no content on it indeed, apart from menu.

    However, this redirect would suggest that mapping is actually working. Since I cannot see how the site looks under original sub-domain (due to the redirects) and I don't have access to site, I can only give some general suggestion right away:

    In case of "shared hosting" usually the strategy that works best is to add "domains to be mapped" as "add-on" domains in cPanel. This should also let you create e-mail accounts for these domains and/or install SSL certificates for them. The only thing you'd need to take care of would be to make sure that a "root folder" setting value for each of these domains is the same path as the one set for "root folder" of you main domain.

    If you do have a dedicated IP and this IP is used only for the Multisite (for the main domain) you can instead use DNS A record for mapped domains but that actually "adds-up" some additional issues: you usually cannot create mails for such domain, it might be difficult to add an SSL certificate to it and also the IP address itself must be set in a way that when you type it into your browser address bar, it would load the main site of your Multisite. It cannot be a redirect but instead it must be a root folder (a.k.a "document root") for IP. That is not always possible in case of shared hosts.

    Getting back to the issue: it seems that mapping itself is working but if I correctly understand your post, there's some issue with content, right? Like - the content is there if you access site via original sub-domain but not if you access via mapped domain? If I'm missing something, let me know please,.

    Would you also enable support access to the site so I could take a closer look at it? To do this, please go to the "Network Admin -> WPMU DEV -> Support" page and click on "Grant support access" button there, then let me know here once it's enabled.

    Best regards,
    Adam

  • Kasia Swiderska

    Hello David,

    From what I see you have mapped your domain and it shows site - one thing I'm noticing is that you mapped it with HTTPS, but certificate belongs to the main domain, so it will not work with mapped one. You will need to change the schema of the mapped domain to HTTP in Tools -> Domain Mapping on your subsite (click the key icon to change).

    So when you are on shared hosting you can't use A record (pointing the domain to IP address) because on shared hostings IP is not dedicated.
    You can only use A record when IP is dedicated and IP opens the main site of your MultiSite. If those two conditions are not true, A record can't be used.

    In this case, I suggest using Add-on domain (not parked). In cPanel you will need to add domain you want to map (defilms.com.au) as add-on domain and point it to the root directory of your WordPress installation.
    Here is an example from SiteGround cPanel of my mapped domain:

    you can see that add-on domain points to another site directory (this is where my Multisite is installed).

    Before you will add the domain as Add-on you will need to change it's DNS to ones of your SiteGround server (they should be in cPanel sidebar under Account Information).

    kind regards,
    Kasia

  • Adam Czajczyk

    Hi David Edwards

    Thanks for enabling support access.

    I checked yours site and first thing that I'd like to suggest is to sort our caching issues. I noticed that you're using both Hummingbirds Page Cache and server cache via SiteGround Optimizer. Even though we're dealing with a different issue, such a situation can easily cause additional unpredictable (and very difficult to diagnose) problems on the site. Since you are using Hummingbird's Asset Optimization, I'd suggest switching of SiteGround caches entirely (you can do it via cPanel - there should be three types of cache there) then clearing up HB cache on site.

    As for domain mapping. I accessed and checked your site and apparently there's currently no domain mapped to any sub-site at all. When I visited defilms.davidedwards.com.au it loads some SiteGround placeholder page.

    I think you have created a "defilms" sub-domain in cPanel for davidedwards.com.au domain, is that right? If yes, you don't need it as you already have a wild-card created for davidedwards.com.au. So, the first step would be to get rid of that sub-domain and stick to a wild-card one.

    That should make your "defilms.davidedwards.com.au" site available again. Once that's done, you'll need to take care of the "defilms.com.au" domain, following Kasia's advice above:

    1. at its domain registrar try to "reset" domain DNS to default
    2. in your host control panel you should fine nameservers' names
    3. at defilms.com.au domain registrar panel find an option to change nameservers and use these nameservers that you found in step 2
    4. on your host in cPanel add the domain as add-on domain (you might need to wait a while for the nameservers to be propagated across the web)
    5. on your host in cPanel set the "root folder" for the defilms.com.au to be the very same as the current "root folder" of the davidedwards.com.au (see Kasia's post above for more detailed info on how to do this).

    At this point the setup should be fine and you should be ready to map the domain so:

    - go to the "Tools -> Domain mapping" page in defilms.davidedwards.com.au dashboard
    - map the defilms.com.au domain to it using "http://" protocol prefix

    It should then be working instantly. Once you got that working, you should also be able to install SSL certificate for defilms.com.au in your cPanel and when it's there, you can switch mapping protocol from http:// to https://

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.