Domain Mapping

I've set up domain mapping plugin in site admin but it is not showing in the site settings.

  • Nithin
    • Support Wizard

    Hi Eric Johnson,

    Hope you are doing good today. :slight_smile:

    Since support access to your site is not enabled at the moment, it's tough to say what exact issue you are facing. The Domain Mapping settings are present inside the Network Dashboard, under Settings > Domain Mapping.

    And to map the subsites the settings should be listed under each subsite, under Tools > Domain Mapping.

    Could you please double check whether you have preformed all the steps mentioned in plugin usage doc, in here:

    https://premium.wpmudev.org/project/domain-mapping/#wpmud-hg-project-documentation

    1) You will see in the /domain-mapping/ folder there is a file called sunrise.php. We need to move that (move, not copy) to the /wp-content/ folder.

    So the path to that file will be:

    /wp-content/sunrise.php

    2) You will have to enter the following line:

    define( 'SUNRISE', 'on' );

    If you can confirm all these steps are already done, and still notice issue. Then please check whether flushing Object Cache in the Manage Hosting page, under "Tools" tab, makes any difference, or not.

    If none of the above steps works, then please grant support staff access so I can take a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access, so that we could get this sorted. Have a nice weekend. :slight_smile:

    Kind Regards,

    Nithin

  • Kris
    • Support

    Hi Eric Johnson

    I’m terribly sorry for the delay. Looks like support access does not work for this domain anymore.

    To avoid such case please send us below data through our secure contact form here https://premium.wpmudev.org/contact/#i-have-a-different-question and make sure that subject is “I have a different question” and:

    – Mark to my attention: ATTN: Krzysztof Tomczyk

    – Site access (login url / username / password)

    – FTP credentials (host / username / password)

    – Link back to this thread

    Please confirm here in thread that you have sent that message.

    This will help us to investigate this more :slight_smile:

    Kind Regards,

    Kris

  • Kris
    • Support

    Hi Eric Johnson

    SFTP connection works fine, as for dashboard data unfortunately you did send only site url, not login url. /wp-admin does not work so I guess you set up in Defender masking login area with custom slug. Could you please re-send us via contact form https://premium.wpmudev.org/contact/#i-have-a-different-question correct site login url, for this site?

    – Mark to my attention: ATTN: Krzysztof Tomczyk

    – Site access (login url / username / password)

    – Link back to this thread

    Please confirm here in thread that you have sent that message.

    Kind Regards,

    Kris

  • Kris
    • Support

    Hi Eric Johnson

    Thank you for all details. I check all settings on your site.

    As Nithin mentioned above mapping option in the subsites should be listed under each subsite, under Tools > Domain Mapping. In your case you combine Domain Mapping with Pro Site plugin and you enabled “Pro” level in Select Pro Sites Levels.

    This mean new subsite created manually will have no status from Pro sites, which make domain mapping option not visible.

    In case user will register site with Pro level they will automatically get access to map domain option. If you want to test this manually like I did on your site, just create new subsite, go to Sites -> All Sites, click on link Manage and extand manually Pro level for this site. After that you will see domain mapping option of this site.

    Hope this clarify whole case here :slight_smile:

    Kind Regards,

    Kris

  • Eric Johnson
    • The Incredible Code Injector

    Ok, I got it sorted out, with a live chat session.

    Vaughan pointed out that I was trying to map my domain name, with the plugin, to the primary site, which I can’t do.

    But, I have to do that in the hosting dashboard, which I was trying to do, but with the wrong domain (www) so there was no option for it.

    I set the correct domain name to the primary.

    Problem solved.

    Thank you for your help!

    – Eric

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.