Domain Mapping

I run a multi-site and am trying to map a client's test domain to it's actual url. I've done this twice before using the WPMU domain mapping plug-in but for some reason this time I am unable to complete the mapping.

I've gone back and read directions which always point me to the "Domain" menu under settings in my network admin dashboard, however my dashboard does not display that menu.

when I type the domain settings url
/wp-admin/network/settings.php?page=dm_domains_admin
directly into my browser I get a message that says I am not allowed to access that page (I am the Super Admin).

I've tried using the domain mapping menu instead but there is no option there to add a new site. What am I doing wrong?

  • Tyler Postle

    Hey kathrynjones,

    To add the domain to one of the subsites you will want to navigate to that subsites admin and go to:

    Tools > Domain Mapping.

    There you can map the domain. I checked your network admin as well and it looks like your menu there is accessible too. You will find it via:

    Network admin > Settings > Domain Mapping. You can't map a domain from there but you can see an overview of all your mapped domains.

    Let me know if you still have any issues on your end accessing any of those pages or if I'm misunderstanding something here.

    Look forward to hearing back :slight_smile:

    Cheers,
    Tyler

  • Tyler Postle

    Hey Kathryn,

    I've just turned off the DNS verification via: Network admin > Settings > Domain Mapping.

    So you will be able to map it now, but if the DNS for the domain you are trying to map isn't setup correctly for the mapping then it still won't work.

    If that is the case, can you let me know what the domain is that you are trying to map?

    If you're using A record domain mapping where you point the domain to your dedicated IP then the problem is that the document root isn't setup correctly, I can see that when I visit your sites IP address directly, it doesn't reach your site. So you will want to contact your host and sure they setup your sites dedicated IP so when accessed directly it opens up your site, which usually means making the documentroot the root of your WP install.

    If you are using parked or add-on domain method of mapping then it could be that it's pointed to the wrong folder.

    Cheers,
    Tyler

  • kathrynjones

    thank you again... so it is "mapped" but "invalid".

    I've done this twice before with the same server set up - and once before with the same domain host - i can't figure out why I am having issues this time.

    The domain is http://melodiawomenschoir.org

    Can you clarify a comment above:

    "I can see that when I visit your sites IP address directly, it doesn't reach your site."

    Are you referring to my domain currently or are you saying IF you knew the domain I needed mapped you would be able to see whether it reached my site directly?

    Kathryn

    • Tyler Postle

      Hey Kathryn,

      The url has to be added to my server via domain add-ons in the c-panel first - I had forgotten that step .

      That may reference exactly what you were saying above about the root folder not being setup correctly....

      Yes, that should do it :slight_smile:

      Just so you can check in-case this happens again in the future, here is what I did to troubleshoot:

      1. I got the IP for your main site using a service such as: http://ipinfo.info/html/ip_checker.php

      2. That told me your sites IP is: 37.60.255.246

      3. When I visit that IP directly in the browser it gives me a SiteGround splash page. That means either you are using shared hosting or the document root for your dedicated IP isn't set to point to your WP install's root. If using only A record mapping, that IP needs to open your site - otherwise your mapped domain will just open that same splash page no matter where it's mapped because it doesn't find the directions that Domain Mapping is giving it. It just goes exactly where that IP directs too.

      4. So if I knew the domain you wanted to map beforehand, I would check the IP for that as well and see if it did indeed match the IP for your site - that would mean that the A record is setup correctly and the only likely issue is the document root setting from above OR that you are on shared hosting.

      5. When you are on shared hosting or can't change the dedicated IP's document root then you need to add the domain you want to map as an "add-on" or "parked" domain with your hosting and point it to the folder that your WP install is in. This way the server knows to direct it to the WP install and then Domain Mapping takes over from there.

      Hope that helps! I found domain mapping extremely confusing when I first became a member here but once I learned generally how it works, then you find that there are generally only a couple issues that can happen - although those issues lead to it not working at all :smiley:

      Cheers,
      Tyler

      I see the domain appears to be mapped correctly now, if you do have any further issues just let us know.

  • kathrynjones

    Another day another domain mapping problem... same multi-site, new url.

    This time I made sure to add the domain to my server first. Still getting the "Domain is unavailable to access message".

    here is where it gets really strange:

    At the top of the domain mapping page on the new site there is a message that says:

    If you want to redirect a domain you will need to add a DNS "A" record pointing at the IP address of this server: 37.60.247.122

    But, as you noted above, my site's ip address is 37.60.255.246

    This discrepancy can be seen again on the network admin domain mapping page, where the dialogue box reads:

    Looks like we are able to resolve your DNS A record(s) for your main domain and fetch the IP address(es) assigned to it. You can use the following IP address(es) to enter in the Server IP Address field below: 37.60.255.246

    BUT - the ip address that auto-populated in the server IP address is 37.60.247.122

    And when I go to the mapped domains tab, all my successfully mapped sites are listed as:

    Record Type: A
    Value: 37.60.247.122

    I wrote to site ground and there response was

    I have checked the case and the IP address 37.60.255.246 is the shared IP address on the account.

    The IP address 37.60.247.122 is assign on different server which we managed (us4.siteground.us).

    What am I not understanding about these different ip addresses? If I change the dialogue box I'm my domain mapping settings to the ...246 ip won't that disrupt my other mapped sites? What is going on???

  • Tyler Postle

    Hey kathrynjones,

    It sounds like both of those IP's are shared IP's and neither are dedicated? They both go to a SiteGround splash page so really neither of them should actually work for mapping.

    In the case where you don't have a dedicated IP, you will want to refer back to #5 in my last post:

    5. When you are on shared hosting or can't change the dedicated IP's document root then you need to add the domain you want to map as an "add-on" or "parked" domain with your hosting and point it to the folder that your WP install is in. This way the server knows to direct it to the WP install and then Domain Mapping takes over from there.

    Have you added any of those domains as add-on or "parked" domains through cPanel?

    Looking at the domain info for your mapped domains it does look like it's being hosted at SiteGround as well, so either you purchased the domains there or you've transferred their web host nameservers to SiteGround?

    Where are the other domains you are trying to map hosted? You will need to point them to SiteGround and then add them as an add-on domain within your cPanel and make sure the add-on domain is pointed to the root folder of your multisite.

    If you have any trouble with this or if it's still not working could you send in your cPanel so I can have a closer look?

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -cPanel login url
    -cPanel username
    -cPanel password
    -link back to this thread for reference
    -any other relevant urls

    **If you grant support access then no need to send in wp-admin

    Talk to you soon!

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.