Domain Mapping: A Record not taking effect

We're trying to get domain mapping working for our first client needing a preexisting domain to be mapped to the site we're building for them. Problem is, I can't even get the A Name record I added via the domain registrar (eNom) to take effect. I added the record several days ago (well over 48 hours, so it's not a propagation issue, I think).

Here's the record I added:
-- host name: angletonfumc.org / address: 72.14.178.34; Record Type: A (Address)

There is just one other preexisting record in the listing of Host Records (of type TXT), but this should have no bearing on the domain mapping, right?

I'm sure the domain isn't resolving correctly since pulling it up returns nothing ("Error code: DNS_PROBE_FINISHED_NXDOMAIN" from the browser) and it's obviously not finding my WordPress install.

Thanks for any advice!

  • Tyler Postle
    • CGO

    Hey wranne,

    Hope you're doing well today and thanks for contacting us!

    Have you added the domain to your installation through wpengine? I have attached a screenshot to illustrate. Let us know if that does the trick :slight_smile:

    Also, you can update Domain Mapping to our most current version too - we're at 4.2.0.1 - that should be available through your dashboard.

    Look forward to hearing back wranne!

    Cheers,
    Tyler

  • wranne
    • Flash Drive

    Thanks for the quick reply. I've just added the domain to the installation in WP Engine. I'm trying to upgrade Domain Mapping now, but after clicking the "Auto Update" button I get a "The plugin is at the latest version." message, even though it's obviously not.

  • Tyler Postle
    • CGO

    Hey Wranne,

    Hope you're doing well today and thanks for your reply.

    That is very odd. Do you mind granting support access? Then we can take a look at it first hand :slight_smile:

    You can grant support access via admin dashboard - WPMU DEV > Support > Support Access > Grant Access.

    We may also need FTP to investigate further. If you would like to send that in now to speed up the process if it is needed then you can send it privately to me though our contact form: https://premium.wpmudev.org/contact/

    Send in:

    Subject: "Attn: Tyler Postle"
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    https://premium.wpmudev.org/contact/

    Look forward to hearing back Wranne!

    Cheers,
    Tyler

  • Tyler Postle
    • CGO

    Hey Wranne,

    I saw your email, thanks for sending that in :slight_smile:

    Redirecting to the sign up page is normal behaviour of the dedicated IP; however, it seems like the domain isn't being mapped correctly.

    Can you deactivate and delete your domain mapping then re-install the latest version via your dashboard. This shouldn't remove any of your settings as they are saved in the database. Just want to make sure we have a fresh set of the latest Domain mapping files.

    Look forward to heairng back wranne! At least we know the A Records are pointing the domain to the right place now :slight_smile:

    Cheers,
    Tyler

  • wranne
    • Flash Drive

    UPDATE: Everything is working now. Turns out the redirecting to the sign up page must have been a caching issue, because I tested the domain in another browser where I wasn't logged into any WordPress sites and it worked. Then I cleared my cache in Chrome and it worked their too. So, angletonfumc.org is resolving appropriately and domain mapping is fully working for me.

    Thanks for your help in all of this!

    -Greg

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.