Domain Mapping and HTTPS

When I turn debug mode in WPMU, I get the error:

Notice: Undefined index: HTTPS in /var/sites/t/tbreak.com/public_html/wp-content/mu-plugins/domain-mapping.php on line 503

Notice: Undefined index: HTTPS in /var/sites/t/tbreak.com/public_html/wp-content/mu-plugins/domain-mapping.php on line 473

Notice: Undefined index: HTTPS in /var/sites/t/tbreak.com/public_html/wp-content/mu-plugins/domain-mapping.php on line 537

All three of these lines have the following code:

$protocol = ( 'on' == strtolower($_SERVER['HTTPS']) ) ? 'https://' : 'http://';

I'm getting a lot of backed issues and trying to figure out anything that can cause the slowdown/timeouts. Could this be one of the issues and if yes, what do I need to change to get rid of it.

  • Barry
    • DEV MAN’s Mascot

    If you are not accessing the admin area in HTTPS, then this server setting won't be set, hence the Notice saying so (though I will change this to do an isset check in the next release).

    It shouldn't be causing an issue with slowdowns or timeouts though.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.