Domain mapping and https not working everywhere on site

I have added an ssl certificate to my domain today.

I setup the https wordpress plugin recommended on this forum (I have been reading other members issues with this) and when logging into an account the https is fine, however as a site it is not showing.

It is the same on all the sites on my multisite. For example

http://theculturedbride.co.uk when you go to login at wp-admin the https shows up but I want the whole site to be https://

Is there something I need to do for the https:// to be the default throughout.

  • Jack Kitterhing
    • Code Norris

    Hi there @chapbookpublishing,

    Hope you're well today and thanks for your question! :slight_smile:

    Are you trying to force https on your main domain only?

    If you are, add the following to your .htaccess.

    RewriteEngine On
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://theculturebride.co.uk/$1 [R,L]

    Any issues, or questions we're here to help. :slight_smile:

    You can find the .htaccess via cPanel > file manager in your websites root (normally public_html).

    If you don't have cPanel, let me know what you use and I'd be happy to help.

    Thanks!

    Kind Regards
    Jack.

  • chapbookpublishing
    • WPMU DEV Initiate

    Thanks Jack

    I want the whole site to show the https:// in a browser not just the admin area

    There are two options in the plugin

    force SSL Admin

    force ssl exclusively

    I chose the first one. Should I select both? I tried that on a couple of sites but it didn't seem to make much of a difference

    I have access to my .htaccess file. Will I have to include the same code for every single site on my multisite?

  • Jack Kitterhing
    • Code Norris

    Hi there @chapbookpublishing,

    Hope you're well today and thanks for the additional information.

    Did you want every domain mapped site to use SSL? or just your main site. If you want just your main site protected, add the code I provided to your .htaccess. :slight_smile:

    If you want all domain mapped sites to be covered by SSL, you will need a Multi-domain SSL certificate, https://www.globalsign.co.uk/ssl/multi-domain-ssl/ can you confirm if you have one of those please? :slight_smile:

    I'm here to help.

    Thanks!

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.