Domain mapping and MarketPress compatibility in 3.1. on subdomain install


I have just upgraded my subdomain wpms install with domain mapping and marketpress plugins and noticed that add to cart button dont work on sites that have a mapped domain. It circulates indefinitely.

I have tried lots of combination but none works.

Also, one general question about domain mapping plugin ….

When used as subfolder, does it works with all others WPMUdev plugins, I mean no restrictions whatsoever.

And in the end, when domain mapping used for subfolders, only thing that has to be made is seting A record for a domain (Right ?) …. that means changing all A record for all mapped domain if changing IP of a server (Right ?) and is there i cName sulution.

Thanks, Marko

P.S. what about MarketPress 1.2, will be soon ????

  • Philip John
    • DEV MAN’s Apprentice

    Hiya Marko!

    First up, welcome to WPMU DEV! :smiley:

    Let me get your set up clear in my head first…. You have a WordPress multi-site installation on a subdomain.


    …and you are using sub-directories for sites as opposed to sub-domains.

    Is this correct?

    So, you then have domain mapping which is mapping domains to those sub-directories.

    What you are saying is that on sub-sites that have a mapped domain, the add to cart button of MarketPress is hitting a redirect loop.

    Are you able to give me any URLs where we can see this in action? If not can you give me example URLs of the following:

    1) The original URL of the sub-site (i.e. without domain mapping enabled)

    2) The new, domain-mapped URL of the sub-site.

    3) The URL that the add to cart button goes to.

    Have you confirmed that the add to cart button works on non-mapped sites?

    Finally, just clarify for me the versions of WordPress, domain mapping and MarketPress you’re using.

    I know that’s a lot but it’s necessary to dig down to where the problem lies.

    To answer your other questions…

    Domain mapping should work with our other plugins no problem :slight_smile:

    I believe it is just A record, yes… but check with the instructions for your specific setup.

    As for times, we don’t have anything definite but you can be sure you’ll know when if you’ve got the Update Notifications plugin installed!


  • maveseli
    • New Recruit

    Hi Phil

    To clarify my problem … I have had wpms 3.0.5 subodmain installation that was working fine until I upgrade to 3.1. and move to a new host. All my questions about subdirectory install is just exploring new ways to overcome problem I had.

    Problem is that MarketPress do not longer work on mapped domain. I have tried and found that without domain mapping MarketPress works fine but with mapped domain ajaxified Add to cart button circulates forever.

    I did lot of googling before posting here but info on this is very low. Only thing that I found and that I think can be a source of a problem is that my reseller account does not jet have a dedicated IP address and therefor a dont have a proper vhost entry.

    If you want to try I will send you a login detais for all wpms install as well for a cpanel and whm … only that maters for me is to sort this out soon as possible.

    If you think dedicated IP address could be a source we can wait to see will it be ok after I buy one.

    And yes, I use latest versions of all plugins.

    Thanks for your time, Marko


  • Philip John
    • DEV MAN’s Apprentice


    Ah okay, I see.

    dont have a proper vhost entry

    That could be the issue here. When using sub-domains can you create a new sub-site and access it as expected?

    If so, please send me details to access your site and I’ll take a look – do this using the contact form, marking it for my attention.



Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.