Domain Mapping beta, huge update, SSO async rewritten!

Change-log:

Better integration with Multi-Domains plugin
Revamped SSO to improve performance and solve issue with out of date token nag, now fully async
Added: Ability to disable single url scheme forcing and mapping exclusion
Added: Better UX for adding and managing mapped domains
Added: Ability to enable multiple mapped domains from admin of the main site
Added: Support for multiple currencies
Fixed: Bug when going from an excluded page to the mapped domain
Fixed: Forcing https for admin and login
Fixed: Better UX for adding and managing mapped domains
Fixed: Punycode class compatibility when some extensions are not installed

Please give it a test and let us know what you think.

  • amused
    • friend of Bill. W.

    yep thanks Tim,
    i knew this already.

    with quite a few really good managed hosting companies out there making life sweeter now its so much more convenient and efficient to just use wordpress.
    Take your updated "Support" plugin for example,
    it can practically replace WHMCS ticket and knowledge base systems.
    ProSites speaks for itself and i hear theres even a big update for that around the corner.
    so basically in my humble opinion wordpress can easily replace WHMCS for providing sites (obviously referring to wordpress sites in a multisite).

    not everyone is fond of having an additional VPS for WHMCS or even being there first off with the managed wordpress hosting offerings.
    i have my own "Silver" eNom account (not the free sub account) and also a ResellerClub reseller account.
    ResellerClub prices seem better and sorry to say but eNoms support is far from the best.
    Also they (ResellerClub ) just added to their reseller white label email plans which i have seen interest on these forums as well.
    convenient to sell other services that depend on DNS all in the same place.
    eNom has just scrapped their SmarterMail reseller email services for a really substandard mail server that sales cannot even say for sure if it can be white labeled with their API.

    the extra ResellerClub option for such a powerful plugin could never be a bad thing i believe.

    https://premium.wpmudev.org/forums/topic/domain-mapping-w-resellerclub-recommended-by-whmcs

    i hope i did not come off as insensitive or callus with my words above after the developer listed the great updates. that was not my intention. i appreciated that they do all the hard brain racking work behind the scenes and don't sometimes get the praise they deserve. well let me be the first to say , opps second after Jack :slight_smile: EXCELLENT work and it is all indeed much appreciated !!!
    i worked in manufacturing for over a decade and i know about seemingly thankless professions all to well.
    not the post but what the hell, "Smush Pro" yesterday was amazing i think i got about %60 off on a few dozen uploaded icons.

    so keep up the amazing work WPMUDEV !!!
    much appreciated !!!
    BLESS !!!

    • Justin
      • The Crimson Coder

      Thanks for this info. I have been working hard learning Pro sites so I can create done for you websites for my customers and am finally getting close to actually putting the product out there.

      I would like to offer my customers their own domain name as well so great that you are sharing your experience. (Now I just have to figure out how its going to work technically :wink:

      Thanks!
      Justin

  • Timothy Bowers
    • Chief Pigeon

    You don't require a VPS to run WHMCS, just decent host that supports or is willing to install Ioncube. Still, a little VPS isn't too expensive these days. :slight_smile:

    I know you already know, but the WHMCS Integration plugin, and provisioning really help to bring WHMCS into WordPress too :slight_smile:

    I have both eNom and Resellerclub, my preference is the latter too. For now the only solution is to use WHMCS. This was the quickest way we could bring many options to Domain Mapping, whilst still allowing us to prioritise other more popular requests you all have. :slight_smile:

    i hope i did not come off as insensitive or callus

    Far from it, you're one of the nicest members we love having here :wink:

    And thanks for the kind words, @Jack Kitterhing ego is already big enough!

    Take care.

    • Sam
      • The Incredible Code Injector

      Hi @Ruslan

      Overally there shouldn't be any problem with php versions 5.2.4+ because i'm constantly testing with 5.2.4, 5.3.29, and 5.6, It'll be great if you could give this beta release a test ( maybe on a test site or after a backup of ur site) and if you still face the issue i'll try to fix it in this release.

      Cheers,
      Sam

  • Site Division
    • Site Builder, Child of Zeus

    I have upgraded and I am not seeing the option as stated below to map domains from the main site.
    Added: Ability to enable multiple mapped domains from admin of the main site
    I also am not getting a return as to whether a domain is available for purchase or not through the Enom gateway.

    I have also been battling a problem with the conflict that is caused with the themify builder since version 4.2.0.3. I am unable to create, edit and save all content with the builder. This update did not fix it.
    https://premium.wpmudev.org/forums/topic/domain-mapping-and-my-frontend-builder#post-864695

    • Sam
      • The Incredible Code Injector

      Hi @Fla0

      For this "Added: Ability to enable multiple mapped domains from admin of the main site": Previously you would need to define a constant to enable multiple mapped domains for each subsite but now you can do it under "Allow multiple mappings per site" from the DM settings page of the main site

      Looking into the issue with builder and will try to have a fix for it in this version.

      Cheers,
      Sam

      • Site Division
        • Site Builder, Child of Zeus

        I guess my question is, Am I suppose to be able to map a or domain multiple domains on the main network site? My site? I have not seen that option for quite some time and yes I did check "Allow multiple mappings per site" but still do not have the option available in my main site. :slight_smile:

        Just an FYI yesterday I completely wiped my network and started fresh and still have the builder problem, had to go back to version 4.2.0.3 again, it works perfect but I would like the new options available and the re-seller-club as well. :slight_smile:

    • Sam
      • The Incredible Code Injector

      Hi @Richard

      Thank you very much for your feedback.
      Please note that these two options don't work on the exclusion table, they just enable/disable the textareas underneath the table that allows subsite admins to exclude/force URLs.
      Anyway I do agree these two options ( or other options ) should allow control on the exclusion table as well, and i'm adding this control.

      Cheers,
      Sam

    • Sam
      • The Incredible Code Injector

      Hi @Fla0,

      Nice to hear you've been able to figure out your issue, nevertheless i'm trying to fix this issue with php 5.3 + DM and themify builder.
      Adding multiple domains to the main site is something done with Multi-Domains plugin and is not in the scope of Domain mapping plugin, but with DM you can add multiple mapped domains to a single subsite/blog.

      Cheer,
      Sam

  • Sybre Waaijer
    • The Incredible Code Injector

    Hello!

    I noticed all translations are gone from WPMUdev. So I'll give it a try :stuck_out_tongue:
    When it's ready I'll be sure to update the translations! Thanks :slight_smile:

    And I tried it!

    Blazing fast loading :slight_smile: I can now also skip the loading and go to other pages when I click them.
    This is really amazing Sam! :smiley: Great work! :smiley:

    I noticed a small bug where everything shows as invalid (well, almost everything). This might be because I use IPv6 as well as IPv4. I'm mainly connected over IPv6.

    Also, the "Enable exclude/forced urls" options aren't doing anything :') but I might be overlooking something :o

    Once again, thanks for this! :slight_smile:

  • Sybre Waaijer
    • The Incredible Code Injector

    @Sam, I would like to add this to my previous post:
    https://blog.sucuri.net/2015/04/security-advisory-xss-vulnerability-affecting-multiple-wordpress-plugins.html
    From: https://developer.wordpress.org/reference/functions/add_query_arg/

    "Note the use of esc_url() before outputting the link. This is necessary because this function does not escape URLs and if output without escaping, would make the page vulnerable to XSS scripting."

    I think I found this vulnerability in Listing.php, but you've done an excellent job everywhere else!
    Could you check it? Just to be safe :3

    Hope you have a wonderful week!
    (this shoutout also goes to Google Analytics Plus, MultiSite Theme Manager and Pro Sites)

  • wp.network
    • The Bug Hunter

    @Sam @Jose

    It seems this beta keeps the fixes needed when using
    define('DM_FORCE_PROTOCOL_ON_MAPPED_DOMAIN', true);
    in wp-config to achieve canonical permalinks for https mapped domains, however SSO is NOT working as expected =(

    Also, this does NOT seem to work with https w/ Mutl-Domains though @Jose's patch work for us had made this work with previous DM beta...

    All my fixes will be included in the next release of DM. (The fix for the DNS wildcard in in MD and it will be included in the next release as well). So, once the new version is released, you can get rid of the beta without worrying.

    We installed a fresh network for this test, only essential plugins and Twenty Fifteen (no .htaccess tricks, all values for SITEURL and HOME use https) - we also cut CloudFlare out of the picture, we are currently using our own nameservers both domains in test have valid WIldcard SSL certs at server.
    Login/Admin at original addresses
    DM set to use Cross-Domain Auto-Login, and to load async

    Network primary is https://wpms.network
    tivism.com was then setup as a Mutli-Domain base, SSO was 'Enabled' and a new subsite was created:
    https://sub1.tivism.com

    Logged in as superadmin to primary, we are NOT able to visit admin for sub1.tivism.com nor does the SSO work on frontend.

    Logging into the frontend of https://sub1.tivism.com with superadmin brought us to network primary, however, we were then able to successfully visit the subsite admin and the admin bar was visible on frontend.

    We the made a second subsite, sub2tivism.wpms.network and used DM to map the following domain to this subsite (selecting 'https' as the protocol):
    https://sub2.tivism.com

    We are able to visit this admin for this subsite just fine, and the frontend resolves and is forced to the mapped domain, however, https is NOT enforced! eg, currently, http://sub2.tivism.com also resolves =(

    The https enforcement can be taken care of with .htaccess and for 100% https setups it can be really easy (though not quite perfect):

    RewriteCond %{HTTPS} !=on
    RewriteRule ^.*$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

    Its when the network is not 100% https that we need to be able rely on the plugin or else need to write complex solutions on our own...

    Further though, the SSO is NOT working for https://sub2.tivism.com frontend either =(

    Even when we logged in directly from frontend of https://sub2.tivism.com with superadmin the admin bar is NOT displayed on frontend (however, the meta-widget and other links are good!)

    We can do some more detailed testing tomorrow and will update our original bug thread to keep this thread clear =)

    https://premium.wpmudev.org/forums/topic/domain-mapping-bug-4033-breaks-https-permalinks-causes-mixed-content

    btw, Support access is active if you want to look at settings, creds for WPMS and server remain the same...

    Cheers, Max

    • Sybre Waaijer
      • The Incredible Code Injector

      Hi @WPMS.CLUB

      Why do you define DM_FORCE_PROTOCOL_ON_MAPPED_DOMAIN()?
      Digging into the code, all I can see is that it defaults the mapping option to https rather than http.

      Anyway, I don't have any issues, I think I'm pretty much using the same server setup as you're using and you're trying to achieve the same result, I assumed?

      Maybe I'm missing something here, but if you could lay out in a table what you exactly need, I might have the answer for you :slight_smile: Tag me in your other post. :3 I smell a misconfiguration somewhere but I'm too lazy to run through a mind-blowing 40 pages (or 15300 words) of content! :o

      • wp.network
        • The Bug Hunter

        Why do you define DM_FORCE_PROTOCOL_ON_MAPPED_DOMAIN()?`

        as I have stated many times, without using this define, permalinks for domains mapped with https as the protocol are not canonical: this means that for a mapped domain, say
        https://sub2.tivism.com
        unless the above define is used, the WPMS believes that the correct permalink value is
        http://sub2.tivism.com

        and then proceeds to use this value in many places, including such places as links back to site in RSS feeds... this is an optimization nightmare (between potential SEO impacts to customer perceptions of links to an extra redirect for every request off a 'bad' permalink, etc).

        Permalinks are called permalinks for a reason and they should represent the actual (canonical) permalink value.

        Imho, one should not need to use the manual define for this, it should just work.

        In this case, I defer to @Sam's greater knowledge given that he has said this should be a manual define...

        There is no misconfiguration though your offer is both gracious and appreciated!

        We tested this very thoroughly and achieved success with @Jose's help.

        There is a bug in the parsing logic for the original url. Therefore, it returns this broken url:
        https:disappointed:htts:disappointed:tivism-secure-1.wpms.network/wp-login.php
        When the browser is not able to find a valid protocol/schema it will treat the url as a relative one, prepending the base url https://tivism.com/.

        The issue with the above define has been resolved and this beta seems to retain those fixes.

        Previously, @Jose's patches had Multi-Domains and SSO working perfectly with https and most of the above post is meant to clarify that this new beta has NOT retained those fixes.

        Cheers, Max

        • Sybre Waaijer
          • The Incredible Code Injector

          Honestly, I've never had troubles with Domain Mapping and SEO.
          The matter of fact, one of my sites is in search result 1 through 4 on Google, and another 3 times on page 2 in Google with the same yet quite a popular search term. Heck, I can't even find the subdomain.mymaindomain.tld of the mentioned site in Google :smiley:

          I remember I've read something about 301 and Canonical, found here:
          http://moz.com/blog/301-redirect-or-relcanonical-which-one-should-you-use

          What I got from that is that when a domain is mapped both the non-mapped domain as the mapped domain need a canonical meta tag pointing to the mapped domain. I dug into this issue today and I'm ready to write a plugin on that one.

          What the plugin must fix, as you can see in the source linked below, the <link rel='canonical' is incorrect and should point to the mapped domain:
          view-source:https://architech.hostmijnpagina.nl/projecten/

          Once that tag is set correctly, Google will go to that page and index further within that page, also looking for the sitemap and the like.
          An example of the sitemap it will look at can be found here, a mapped domain: https://meteenonline.nl/feed/
          As you can see, all links are correct.
          Even in a comment feed of a non-HTTPS domain is displaying perfectly:
          http://verbijmontage.nl/2014/11/26/dit-is-mijn-nieuwstitel/feed/

          Other than that, I can't really see an issue with SEO ranking.

          Of course, I've only briefly scanned the moz.com's blog so I might be off by a bit.

          However, I wonder if everything works correctly (except for the SEO optimization) when you're not using DM_FORCE_PROTOCOL_ON_MAPPED_DOMAIN()?
          I think it's a manual define because it tends to be buggy, I can also find no easy documentation on this one without searching Google for it :3

          PS. Oh, I would like to add that this iframe SSO technique helped one of my AJAX driven themes to not bounce and reload statically every page fetch whilst being logged in. Great job on finding the alternative @Sam <3 It's brilliant! :smiley:

          • wp.network
            • The Bug Hunter

            @Sybre you're really awesome!!

            You have some good points there and some excellent research... my general point though is that we have much less to *worry* about (and work at) if the canonical value is actually used for permalink value.

            Our interest is first and foremost in 100% https networks and use of a manual define for such environments seems appropriate enough.

            If using the define creates issues with the using the new granular page controls for environments using mixed protocols then we'll just have to pick between the issues and the permalinks (and then do our best due diligence for optimization) until some other solution is found.

            I wonder if everything works correctly (except for the SEO optimization) when you're not using DM_FORCE_PROTOCOL_ON_MAPPED_DOMAIN()?

            This is an excellent question, obviously. However, the answer is: No

            We removed the define and all above noted behaviors remain consistent, and as expected, permalinks for https mapped domains are no longer canonical...

            Cheers, Max

          • Jose
            • Bruno Diaz

            Hi there @Max,

            Hope you are doing great.

            I just read through your posts. Let me see if I understood correctly.
            When DM_FORCE_PROTOCOL_ON_MAPPED_DOMAIN is defined to true, the only issue that you experience is the SSO?
            SSO has been completely rewritten by Sam. So, any feedback is appreciated.
            Does it fail only when using MD?

            Please advise.

            Cheers!
            Jose

          • wp.network
            • The Bug Hunter

            @Jose thanks for jumping in here =)

            @Sybre and I were discussing the context for use of DM_FORCE_PROTOCOL_ON_MAPPED_DOMAIN - I believe that the fixes you made for this issue have been maintained into this current beta.

            Again, DM_FORCE_PROTOCOL_ON_MAPPED_DOMAIN is not the issue, the below noted behaviors occur regardless of whether this define is used.

            We installed a fresh network for this test, only essential plugins and Twenty Fifteen (no .htaccess tricks, all values for SITEURL and HOME use https) - we also cut CloudFlare out of the picture, we are currently using our own nameservers both domains in test have valid WIldcard SSL certs at server.
            Login/Admin at original addresses
            DM set to use Cross-Domain Auto-Login, and to load async

            Network primary is https://wpms.network
            tivism.com was then setup as a Mutli-Domain base, SSO was 'Enabled' and a new subsite was created:
            https://sub1.tivism.com

            Logged in as superadmin to primary, we are NOT able to visit admin for sub1.tivism.com nor does the SSO work on frontend.

            Logging into the frontend of https://sub1.tivism.com with superadmin brought us to network primary, however, we were then able to successfully visit the subsite admin and the admin bar was visible on frontend.

            We the made a second subsite, sub2tivism.wpms.network and used DM to map the following domain to this subsite (selecting 'https' as the protocol):
            https://sub2.tivism.com

            We are able to visit this admin for this subsite just fine, and the frontend resolves and is forced to the mapped domain, however, https is NOT enforced! eg, currently, http://sub2.tivism.com also resolves

            Further though, the SSO is NOT working for https://sub2.tivism.com frontend

            Even when we logged in directly from frontend of https://sub2.tivism.com with superadmin the admin bar is NOT displayed on frontend (however, the meta-widget and other links are good!)

            I will rollback MD and will report =)

            Cheers, Max

          • Sybre Waaijer
            • The Incredible Code Injector

            @WPMS.CLUB & @Sam

            I want to lay down this issue here because I too have encountered it when a colleague posted something using the WordPress media uploader. Of course there was an issue when you don't automatically change http:// to https:// or in case of domain mapping (mixed http/https) using simply //.

            Now, the core issue might lay here, in ms-blog.php (WP core)

            /**
             * Get a full blog URL, given a blog id.
             *
             * @since MU
             *
             * @param int $blog_id Blog ID
             * @return string Full URL of the blog if found. Empty string if not.
             */
            function get_blogaddress_by_id( $blog_id ) {
            	$bloginfo = get_blog_details( (int) $blog_id, false ); // only get bare details!
            	return ( $bloginfo ) ? esc_url( 'http://' . $bloginfo->domain . $bloginfo->path ) : '';
            }

            As you can see http:// is hard coded.
            This issue has been placed here for over 5 years now:
            https://core.trac.wordpress.org/ticket/14867

            But instead, we get unreadable emoji :smiley:

            Anyway, just my 2 cents. I'll look into a hard-coding fix for when the user uses a media upload. Content scanning is heavy so I will see how I can contribute without lagging my website, maybe I'll just filter the content the moment the user presses "save changes" and replace all http:// with // when linked to meta types like images or files.

            Intrusive, but maybe better than this:
            https://codex.wordpress.org/Function_Reference/capital_P_dangit

            Anyway, Max, have you tried to set "administration mapping" to the domain entered by user? wp_redirect should take care of this after logging in I assumed. From there the scheme should be automatically correct.

  • Ben
    • The Reaper

    @Sam

    I have a live site so I am unable to test this, on my live site, but I have a serious question that I asked a while back about before I believe you were around, and now that I am more knowledgable about the systems I realize the people who previously asked the question were not familiar with the situation.

    The use case is as follow:

    "http://subblog1domain.com" has both domain mapping and marketpress installed.

    1. The user goes to "http://subblog1domain.com" and adds a product to their shopping. They can view their cart.
    2. The user then clicks checkout now which will bring them to: https://networkname.com/subblog1/store/shopping-cart/shipping/
    3. The user then completes the order

    However there are 2 impediments in the way:
    1. https://networkname.com/subblog1/ will not carry over the shopping cart information. I was told this was impossible a by wpmudev developer Jonathan a while a go...but I guess he is gone...and he was completely 100% wrong.
    2. Need to make it so that https://networkname.com/subblog1 doesn't forward to HTTPS://subblog1domain.com

    This is the way wix and square and shopify handle their shopping carts on their lower level packages because it makes it so that a secure transaction can occur without the need to set up SSL for every domain that is added.

    HUGE hole in the domainmapping/marketpress combo....is there a workaround for this or is this just how it is? And does this update address that issue? Thanks for your work @Sam

    • Sam
      • The Incredible Code Injector

      Hi @Ben

      The simple answer is that this update doesn't address the items you're mentioning but:
      - I'm talking to the Marketplace developer to implement a solution for item 1
      - Item 2: you already can exclude some urls from being on ssl or being mapped ( from the settings section of DM plugin in the subsite)

      Cheers,
      Sam

  • RobJames
    • WPMU DEV Initiate

    Not sure if i came across a bug or not while testing this however I installed the plugin on a fresh multisite installation with pro-sites.

    The plugin installed with no errors or problems (with debug mode on). However once i tried to add a domain to a subsite it would not process, on clicking "Map Domain" the spinner would show briefly then nothing.

    Anyway on digging further I did a NET test on Firebug while clicked the button which returned the call for admin-ajax.php etc and gave a code 200 OK - but it was not working. Digging further into to that and finding a embedded error of Fatal error: Cannot redeclare _mb_strlen() (previously declared in /var/www/vhosts/**mydomain**/wp-includes/compat.php:41) in /var/www/vhosts/**mydomain**/wp-content/plugins/domain-mapping/classes/Vendor/Punycode.php on line 5 (mydomain removed.)

    So I looked a little further and opened Punycode.php within the plugin, and the first function call is

    function _mb_strlen($str) {
    	$charset = get_option( 'blog_charset' );
    	return !in_array( $charset, array('utf8', 'utf-8', 'UTF8', 'UTF-8') ) ? strlen(utf8_decode($str)) : strlen($str);
    }
    
    if ( !function_exists('mb_strlen') ):
    	function mb_strlen( $str ) {
    		return _mb_strlen($str);
    	}
    endif;

    So from the error this function is being called in a wordpress core file, so i made the following changes:

    function __mb_strlen($str) {
    	$charset = get_option( 'blog_charset' );
    	return !in_array( $charset, array('utf8', 'utf-8', 'UTF8', 'UTF-8') ) ? strlen(utf8_decode($str)) : strlen($str);
    }
    
    if ( !function_exists('mb_strlen') ):
    	function mb_strlen( $str ) {
    		return __mb_strlen($str);
    	}
    endif;

    Simply adding a extra _ underscore to the first function on line 2 of the file and on line 9 and it works perfectly now, nice and snappy domain adding.

    • Sybre Waaijer
      • The Incredible Code Injector

      @RobJames Good find!

      @Sam the function _mb_strlen() is new in compat.php on line 41 in WordPress 4.2, please address this issue ASAP with the highest priority <3 Renaming would suffice :3

      Thanks!

      P.S. I think this has been added in contribution with Emoji support.
      P.P.S. I think not using the WP core's _mb_strlen() is the best way to still support old WP versions (although deemed to be vulnerable to XSS attacks!)

  • RobJames
    • WPMU DEV Initiate

    Ah glad it wasn't a single time issue i was having.

    Would it not be more reasonable if you did want to enable this for older versions to have a checkbox in the admin area, including a warning something like:

    "Use Non WordPress mb_strlen - Note: possible XSS vulnerability, for use on versions prior to WordPress 4.2 - use at your own risk." [checkbox]

    However to not punish those of us who like to keep up to date and secure by default it uses the WordPress Core version, or even vise versa - by default use the plugin in built, then give us the option to disable it and use the WordPress core version until a time where everyone should have a updated wp installation.

  • Patricia BT
    • Connector

    Hi @Sam,
    my setup is a multisite, with several domains to main site (with multi-domains), some are available for customers of the multisite to create their subdomains to, some not. Then the customers can map their domain. Some have WPML on their site, and this was an issue with 4.3.0.x as I tried to solve with your staff, you can read about it here: https://premium.wpmudev.org/forums/topic/domain-mapping-4302-with-wpml

    With this beta, it seems that the issue is solved (with WPML on a subsite with domain mapped), and that I have been able to add the WPML sunrise path inside the new sunrise.php

    However, this beta made new bug (solved when I reverted back to 4.2.0.6). In the same mutlisite setup (I must also mention I use Pro Sites), when using this Domain Mapping Beta version, all the sites (but the main) do disappear from network admin > Sites (list all), as well as in the list in network admin-> Domain Mapping -> Mapped Domains (tab).

    I will check that more and do more tests, but I'm glad that this is ok as I had to reverse to 4.2.0.6 (and I don't like to run sites with non-updated plugins, makes me nervous :wink: )

    Feel free to contact me for further testing.

    Thx a lot and looking forward to the release :slight_smile:
    Have a great day
    Patricia BT

  • SD2k
    • The Crimson Coder

    Looking forward to this upgrade!

    Are you aware of any other users who are having issues with mapping domains on wpengine?

    My domains are mapping but show up as invalid.

    They are also reachable by both subdomain name and mapped URL even though I have settings set to 'Mapped Domain' only.

    Any idea when this is set for release?!

  • Steve
    • Design Lord, Child of Thor

    The issue I mentioned here is fixed, thanks!
    https://premium.wpmudev.org/forums/topic/i-just-installed-4304-and-although-i-really-like-the-new#post-845923

    I'm seeing some general bugginess with switching sites having to login again (and not being able to no matter how many times I enter my credentials). It typically happens when I switch to a different site in my network and then click one of the admin menu items in the top admin bar.

  • Sam
    • The Incredible Code Injector

    Dear Members

    Thank you so much for taking your time to test this beta version and thanks for all your sweet and valuable comments in this period.

    Version 4.4.0 is out and i highly recommend upgrading. Hope you're not facing bugs with this version, but if you do don't hesitate to let us know and we'll try to fix them up for you as soon as possible,

    Cheers,
    Sam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.