[Domain Mapping] Cannot purchase domains via eNom

I installed Domain Mapping yesterday, set up eNom and bought a domain with It (twice!). But it doesn't seem to work, although PayPal seems to have charged the amount but the domain doesn't seem to be bought and linked. Please advice.

  • Nahid

    Hey Bernard !
    Hope you are having a great day!

    Nahid here, following up from our last Live Chat session. Unfortunately, I wasn't able to run the troubleshooting tests on your site due to not being able to set up a test environment for eNom as I do not have access to your eNom account. Could you please go through the following troubleshooting tests which'd help us determine the source of the issue?

    1. Plugin/theme conflict test: Try running a full plugin/theme conflict test just to make sure no other plugin(s)/the theme on your site is/are conflicting with Domain Mapping and thus causing the issue. The basic concept is to temporarily disable all the plugins except Domain Mapping (and WPMU DEV Dashboard), switch to a default WordPress theme and check if the issue still persists. If it doesn't, please enable all plugins and the theme one after another to see activating which brings back the issue. This handy flowchart can help you do a full plugin/theme conflict test.

    2. Enable debugging: If the plugin/theme conflict test doesn't help, please enable WP_DEBUG. You can enable debugging by putting the following constants in the wp-config.php file:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    These constants must be added before the line "/* That's all, stop editing! Happy blogging. */" for them to work. Please make sure identical constants are replaced if they were already there previously.

    Enabling debugging in WordPress will log any errors that the site encounters in a log file named "debug.log" located in the "wp-content" folder. Please upload the debug.log file in a cloud storage platform like Dropbox and attach the shared link in your next response so that we can take a look into it. You can know more about WordPress debugging in this handy article.

    Note: It is highly recommended that the site is backed up before the tests or the tests are done in a cloned staging site.

    Hope this helps. We'll be looking forward to hearing from you. Thanks!

    Kind regards,
    Nahid

  • Bernard

    Thank you for your response.

    I have two additional questions:

    - how can I disable the plugins on only one site of my multisite, without influencing the others?

    - does this mean anything:

    You are using an old version of /customers/1/4/b/lifehost.org/httpd.www/wp-content/sunrise.php file. Please, replace that file with a new version which is located by following path: /customers/1/4/b/lifehost.org/httpd.www/wp-content/plugins/domain-mapping/sunrise.php. I have already

    I have already replaced the file twice, without the error to be resolved

  • Nahid

    Hey Bernard !
    Hope you are doing well today!

    how can I disable the plugins on only one site of my multisite, without influencing the others?

    The plugins which are "network activated" cannot be disabled site-wise. They can be "network deactivated" which influences the whole network, i.e. all sites. Only the plugins which are activated site-wise can be deactivated from that respective site without influencing the others.

    does this mean anything:
    "You are using an old version of /customers/1/4/b/lifehost.org/httpd.www/wp-content/sunrise.php file. Please, replace that file with a new version which is located by following path: /customers/1/4/b/lifehost.org/httpd.www/wp-content/plugins/domain-mapping/sunrise.php. I have already"
    I have already replaced the file twice, without the error to be resolved

    This error message was showing up because the "SUNRISE" constant definition was added in a wrong position in the wp-config.php file. I have changed it's position so that it is added before /* That's all, stop editing! Happy blogging. */ and the error message isn't showing up anymore. Here's a screenshot for reference:

    Hope this helps. We'll be looking forward to hearing back from you. Thanks!

    Kind regards,
    Nahid

  • Dimitris

    Hello Bernard,

    hope you're doing good today and don't mind me chip in here! :slight_smile:

    Yes, this could be a reason, so please test eNom functionality once more.

    If you're still having these issues, then you should either perform a conflict test like my colleague Nahid proposed above, or create a staging environment in the same server and do the conflict test there.
    By staging environment we mean a complete and exact copy of this installation into another location/folder in the same server. You can also test this by installing a new WP multisite in the same server and only install WPMUDEV Dashboard and Domain Mapping plugin. Then check how's the eNom integration. :wink:

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.