Domain Mapping - causing 500 soon as I define('SUNRISE', 'on') in my config

This is a brand new multi-network and I have 3 sites on camarata.us (main, ali and aric). I installed Domain Mapping from the WPMU Dashboard then Network Enabled it and went to it's config page. Saw the notice to copy sunrise.php and define the constant. Soon as I did that my server gave 500 everywhere. Commented out the define sunrise line and back to working. I really want to use this plugin and this is a new server. Please help.

  • Luís

    Hi @ussunnah,

    Hope you're doing well today!

    Please, make sure you added the constant correctly to wp-config.php with the semi-colon at the end. Like this:

    define('SUNRISE', 'on');

    If all is correct, can you send us the FTP details of your website, so we can investigate it further?

    Please send it privately through our contact form:

    https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Luis Lopes"
    - WordPress admin username
    - WordPress admin password
    - Login url
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant urls

    Cheers, Luís

  • us-Sunnah

    I had to migrate to a new server which gave me the opportunity re-install from scratch. I am using a multi-network and am trying to set this up again on the primary site "camarata.us" which I have installed and network enabled the Domain Mapping plugin. I copied the sunrise.php file to wp-content and defined the constant in the wp-config.php. After this I am still getting this error message:

    You use old version of /var/www/html/wp-content/sunrise.php file. Please, replace that file with new version which is located by following path: /var/www/html/wp-content/plugins/domain-mapping/sunrise.php.

    I changed ownership of the sunrise.php to www-data and am still getting this error. I would like to try setting up the Camarata Network (camarata.us) to use this plugin and the first site to test successfully is assigning "ali.camarata.us" to "alicamarata.com"

    I have granted support access to the Camarata network (camarata.us) and sent the above contact form to you but we only use SSH with the corresponding public keys so I would need that via email to begin.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.