Domain mapping changed with Wordpress 3.9

Since I upgraded to Wordrpess 3.9 I have noticed that the domain http://www.sealislandmedia.com now ends up on the site not found page.

It used to point to http://sealislandmedia.com.

Any suggestions?

  • Vaughan
    • Support/SLS MockingJay

    Hi @Tim Neale,

    I have just tested this on my multisite using latest domain mapping and wp 3.9, it worked fine.

    Can you check that sunrise.php exists still in your /wp-content folder? If not can you copy the sunrise.php from wp-content/plugins/domain-mapping to your /wp-content folder.

    Hope this helps

  • Tim Neale
    • Site Builder, Child of Zeus

    Yes sunrise.php still exists it is the same version as in the plugin directory.

    The www. function still maps to a mapped domain such as
    http://tomorrow-is-here.org/
    http://www.tomorrow-is-here.org/

    But it fails on the root site

    http://www.sealislandmedia.com/ goes to http://sealislandmedia.com/site-not-found/

    and http://sealislandmedia.com/ is ok

    I have several multi-site set up with 2 different hosting companies, the problem is on all 4 of them. WWW. on the root site goes to site not found.

  • Jack Kitterhing
    • Code Norris

    Hi there @Tim Neale,

    Hope you're well today and thanks for the additional information.

    Can you paste your .htaccess here please?

    Could you also try adding this to your wp-config.php above the line reading that's all stop editing happy blogging!

    define( 'NOBLOGREDIRECT', 'http://sealislandmedia.com/' );

    Thanks!

    Kind Regards
    Jack.

  • Tim Neale
    • Site Builder, Child of Zeus

    Hi Jack,

    .htaccess
    <files wp-config.php>
    order allow,deny
    deny from all
    </files>

    RewriteEngine On

    RewriteCond %{HTTP_HOST} ^easyparishcouncilwebsites\.co\.uk$ [OR]
    RewriteCond %{HTTP_HOST} ^www\.easyparishcouncilwebsites\.co\.uk$
    RewriteRule ^/?$ "http\:\/\/easyparishcouncilwebsites\.com\/" [R=301,L]

    RewriteCond %{HTTP_HOST} ^easyparishcouncilwebsites\.org\.uk$ [OR]
    RewriteCond %{HTTP_HOST} ^www\.easyparishcouncilwebsites\.org\.uk$
    RewriteRule ^/?$ "http\:\/\/easyparishcouncilwebsites\.com\/" [R=301,L]

    RewriteCond %{HTTP_HOST} ^easyparishcouncilwebsites\.net$ [OR]
    RewriteCond %{HTTP_HOST} ^www\.easyparishcouncilwebsites\.net$
    RewriteRule ^/?$ "http\:\/\/easyparishcouncilwebsites\.com\/" [R=301,L]

    RewriteCond %{HTTP_HOST} ^easyparishcouncilwebsites\.org$ [OR]
    RewriteCond %{HTTP_HOST} ^www\.easyparishcouncilwebsites\.org$
    RewriteRule ^/?$ "http\:\/\/easyparishcouncilwebsites\.com\/" [R=301,L]

    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    <Files 403.shtml>
    order allow,deny
    allow from all
    </Files>

    deny from 37.59.189.183

    #Silence is Golden Guard plugin
    Options -Indexes

    I already have the following in the
    define('NOBLOGREDIRECT', 'http://sealislandmedia.com/site-not-found');
    This is as required.
    The issue is that previously there was no redirect on http://www.sealislandmedia.com but now there is

  • Sam
    • The Incredible Code Injector

    Hi @Tim

    I deactivated Domain Mapping plugin for some seconds and the www link redirected to not found page.

    Please rename sunrise.php ( which is located in wp-content directory) to something else and deactivate Domain Mapping and see if you still see www url redirecting to not found page.

    Please keep me posted.

    Thanks

  • Tim Neale
    • Site Builder, Child of Zeus

    I renamed sunrise.php to NOsunrise___.php
    I deactivated the plugin
    I cleared my browser history and ipconfig /flushdns

    The domain mapping is still working for the mapped domains such as tomorrow-is-here.org. But But the wordpress site has links of the format tomorrow-is-here-org.sealislandmedia.com

    www url for the root site is redirecting to not found page.

  • Sam
    • The Incredible Code Injector

    Please visit https://premium.wpmudev.org/contact/

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    - Mark to my attention - ATTN: Sam Najian
    - Link back to this thread
    - Include admin/network access
    - Include cPanel (I will need to look at the DB so need PHPMyAdmin or similar)
    - Include FTP
    - Include any relevant URLS for your site

  • Sam
    • The Incredible Code Injector

    @Tim Neale

    For domain mapping to fully deactivate first it should be deactivated then the sunrise.php file should be renamed, i did that to deactivate the Domain Mapping plugin, even with that deactivated www was getting a not found response.

    1) The problem can't be from domain mapping plugin

    2) There was the following in you wp-config.php file:
    define('NOBLOGREDIRECT', 'http://sealislandmedia.com/site-not-found');
    which would redirect www to site-not-found page, i commented that and now your www redirects to the correct domain without www

  • Tim Neale
    • Site Builder, Child of Zeus

    Sam,
    I was and am aware of the NOBLOGREDIRECT to site-not-found'. It has been there for some time. Because I wanted this to happen. (see above).

    The problem is that previously even with this line in the wp-config.php the URL with the www was being mapped to the correct domain. I.e It was not being redirected. Now http://www.sealislandmedia.com is being redirected because it is being counted as 'blog not found'.

    This represents a degradation of functionality.

    I now have a choice between having no redirect for un-found blogs OR having the root www being redirected to the site not found page.

    Again this was not happening previously.

    I think I shall trying redirecting the www. in the .htaccess file. to work around this.

  • Sam
    • The Incredible Code Injector

    @Tim Neale

    My investigations don't prove relationship between the condition you are facing and Domain mapping plugin, . htaccess is a good resolution.

    Please feel free to contact us should you need any help with that.

  • Tim Neale
    • Site Builder, Child of Zeus

    HI Sam,
    I used this which appears to work fine.

    RewriteCond %{HTTP_HOST} ^www\.sealislandmedia\.com$
    RewriteRule ^/?$ "http\:\/\/sealislandmedia\.com\/" [R=301,L]

    I have looked at two different servers with two different companies. Both show NOBLOGREDIRECT on http://www.rootsite.com. So something must have changed somewhere.

    It might be an enhancement for a future version domain mapping to handle this.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.