Domain Mapping Conflict with Divi Visual Builder

There's a known plugin conflict between divi theme/plugin and domain plugging that prevents the visual builder from not loading on the front end.

On a multisite installation that has a domain mapped subsite, the divi front end visual builder will not work.

Factors to consider when replicating the problem
Original domain must have SSL wildcard
Force SSL using original domain on admin pages & login pages must be enabled
Force SSL on (unmapped) subsites on the front.

Please fix asap.
Thanks
PS.,
Support Access is granted

  • zspri
    • Design Lord, Child of Thor

    Hi Predrag Dubajic ,
    I tried the version above and it partially works. Out of 6 domains that are currently mapped, it worked on just one of them. I compared the one domain that worked with the other 5 that didn't, and I did not notice any difference in settings.
    The plugin you provided above works by DISABLING domain mapping.
    For example, when you enter a mapped domain (connected to a subsite), the subsite url will show instead of the mapped domain.

    As the domain mapping plugin is clearly in conflict with the front end visual editors, here is the solution that I propose:
    Create an option within the domain mapping plugin to disable domain mapping only on pages that have a designated string as part of their url. For example, divi uses the ?et_fb=1 string at the end of its visual builder urls. Therefore if a setting can added to exclude urls that have the user-inputted suffix (as each page builder has it's own suffix) that would work just perfectly.

    Thanks

  • Predrag Dubajic
    • Support

    Hi zspri,

    Thanks for the info, can you please try the latest beta that has some further improvements and our tests are showing that it works fine with Divi now.

    Domain Mapping currently supports only absolute URL exclusion, I'll check with the devs if we could add relative URL in future as well.

    Best regards,
    Predrag

  • zspri
    • Design Lord, Child of Thor

    Hi Predrag Dubajic,
    I just tried the latest update and the problem still persists as described above. I modified the global settings trying different setting combinations to no avail. On your test install, do you have multiple subsites that are domain mapped? Because as mentioned earlier, only 1 out of 6 mapped domains works with this update. The other 5 domains are forced/redirected into subdomain urls. Can you provide me with the settings you input and also confirm that this update works when multiple subdomains are domain mapped?
    Thanks

    Ps.,
    My current settings are as follows:
    administration mapping - original domain (in order to use wildcard ssl from networkdomain.com)
    login mapping - original domain (in order to use wildcard ssl)
    cross domain auto logging - no
    verify domain dns settings - yes
    check domain propagation before mapping - yes
    for original domain:
    - force https for login and admin pages - yes (in order to use wildcard ssl)
    - force https for front end pages - yes (in order to use wildcard ssl)

  • Predrag Dubajic
    • Support

    Hi zspri,

    We have our QA team testing this on multiple installations so it was tested with different settups.

    Can you grant me support access to your site and tell me which subsite is working and which ones are not so I could compare the settings and try replicating this again?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Best regards,
    Predrag

  • Lamarr
    • WPMU DEV Initiate

    Any progress on this issue? I am experiencing the same issues as described. After implementing SSL ( which is a SEO must after the Google announcement ) I am experiencing the exact same problem as described above with the visual builder.

  • zspri
    • Design Lord, Child of Thor

    It turns out that domain mapping not only breaks divi builder but also beaver builder. At this rate it is safe to assume that domain mapping is not complete with any front end page builder. Can a solution please provided to this please? It's been almost a year without any solution...

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.