Domain mapping conflicts with User Switching

I'm using your Domain Mapping plugin on a multisite, ever since we set that up. The User Switching plugin no longer works.
I just tried deactivating domain mapping and commenting out the 'sunrise' line, and User Switching started working again.

  • James Morris

    Hello Shaun,

    I hope you are well today. I'll be following up with you regarding your chat.

    I've just tested this out on a fresh install of WordPress 4.8.2 with only WPMU DEV Dashboard, Domain Mapping and User Switching enabled.

    Domain Mapping is fully configured with sunrise.php defined and all is working correctly. I then activated User Switching and tested it as well. There were no issues.

    My environment:
    PHP 7.0.23
    WP 4.8.2 Multisite
    WPMU DEV Dashboard 4.4
    Domain Mapping 4.4.2.5
    User Switching 1.2.0

    Full debug.log was enabled and there was no errors, warnings or notices. Everything seems to be working well.

    It's possible that there is another conflict going on with your site that is causing this. I see in the chat transcript that a full plugin conflict test was not performed? Would you please go ahead and perform a full plugin conflict test to help isolate the source of the problem?

    The simplest way to perform a plugin conflict test:
    * Login to your site via FTP
    * Navigate to wp-content
    * Rename the plugins folder to _plugins
    * Create a new folder named plugins
    * Move the plugin folders (ex: wpmudev-updates, domain-mapping and user-switching) you want to test from _plugins to plugins
    * Then, one at a time, move other plugin folders over from _plugins to plugins until the symptom returns

    NOTE: While you are doing this, do not visit WP Admin -> Plugins on your site. This will ensure that your plugins remain active when you copy them back over.

    Also, please enable WP_DEBUG while you perform this test as the output can give some better clues as to what's going on.

    To enable WP_DEBUG, change the following line in your wp-config.php file:

    define('WP_DEBUG', false);

    To this:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    After you've visited the pages that are causing you problems, please go to wp-content/ on your server via FTP and download the debug.log file to your local computer. Then, open that file with a text editor like notepad (Windows), GEdit (Linux), or TextEdit (Mac). You can then save the file as a .txt file and upload it here as an attachment to your post.

    I look forward to seeing the results of your tests.

    Best regards,

    James Morris