Domain Mapping - Domain Unavailable

Trying to map a domain from multisite and receiving the Can Not Access new Domain Error. I tried 2 domains and one the DNS look up is showing that it is pointing to my server and one is showing that it isnt. Its been 24 hours and I know it says it can take 72 hours but really it usually takes 15 minutes. I am getting the same error on both sites. I added an A record to point to my servers IP Address. In the section where I believe it says points to I added the @ sign under my godaddy account. The other domain is with hostgator and it would not allow me to use the @ sign. The site with hostgator is the one that DNS look up says is set up correct. I am trying to map flyway.freedomwave.net to flywaycarpetcleaning.com and clints.freedomwave.net to fightingthefish.com. If you want to look in my register please let me know and I will give credentials. Thanks so much for the help!

  • Dimitris

    Hey there Justin,

    hope you're doing good and thanks for reaching us! :slight_smile:

    I just went ahead and inspected your Domain Mapping settings after you kindly provided support access for us, and I realised that the IP addresses caught in DM are leading to a "Direct IP access not allowed" page from CloudFlare.
    As a static IP address which should be pointing to the root folder of the multisite installation (so resolving to the main site of it) is required, please have a read at this thread to help you proper setup this.
    https://premium.wpmudev.org/forums/topic/domain-mapping-plugin-and-cloudflare

    Feel free to post back here if more assistance is required on this, and please describe the exact steps that have been made so far! :slight_smile:

    Warm regards,
    Dimitris

  • Justin

    I just sent this to flywheel support they are usually pretty helpful with these kinds of questions but I would really like your feedback as well. thanks! ......

    Hey guys I have a question that I know doesn't totally apply to flywheel support but I would really appreciate any advice. I am trying to map a domain in my multi site network at http://www.freedomwave.net I have discovered that it isn't working because of cloud flare. I am not actually using cloud flare for anything besides an SSL certificate. I would like to deactivate cloud flare but I am really worried that because I have the dns settings pointing to cloud flare that I will lose sites on my multi site network. What do you guys think? Do you think I could just deactivate it? Thanks!

  • Adam Czajczyk

    Hello Justin!

    If you are not using CloudFlare and they would be able to disable it for you that would probably make things easier.

    I think though there may be also other issues to address. I checked both the domains that you wish to map to the sub-sites of your Multisite and here's what I found:

    - the "flywaycarpetcleaning.com" doesn't resolve for me at all and that means that either DNS settings had not propagated properly yet or it's misconfigured

    - the "fightingthefish.com" domain does resolve and it leads to the default Flywheel's "host page".

    Let me focus on that second domain then. It seems that the domain points to the server but no site existst for it. I'm not familiar with Flywheel's server management panel but it seems that the domain has not been added to your account. What you would like to do would be to:
    - log into your Flywheel account
    - use "Add domain" option to add that domain to your account
    - make sure that the "root folder" (sometimes referred to as "document root" as well) is set to be the same as "root folder" for your main domain

    As a result, before being mapped the "fightingthefish.com" domain should load your main site and when it does, you should be able to map it to the sub-site. Then you could simply "mimic" the same setup and steps for other domains that you wish to map.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.