Domain Mapping - Health Status for Domain is Invalid

Having trouble mapping my domain. Addon domain has already been built but it's not mapping correctly.

Thanks. I appreciate your help.

  • Dimitris

    Hey there David,

    hope you're doing good and thanks for joining us!

    That's more probably happening because the nameservers and/or the DNS records (whichever changes you've made) haven't propagated yet.
    Have you tried to disable the "Check domain propagation before mapping" option in network admin area under Settings -> Domain Mapping?

    By doing this, and even disabling the "Verify domain's DNS settings" option right above this, you should be able to map any domain name despite its settings.

    Also, please ensure that the addon domain is using the exact same directory on your server as your WP multisite installation. This could be /public_html/ but it may varies on your case.

    Let me know how that goes! If you still encounter issues, please further elaborate on your setup (server type, static IP or not, DNS records etc) and grant us with support access to your website as described here: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Warm regards,
    Dimitris

  • David

    Thanks Dimitris. Sorry for the late response. I set up a support access to my site. Do I need to do anything else to get help using my support request? Sorry, I called you Dimitri in my support request .

    Here's the text I posted:
    This is regarding this question: https://premium.wpmudev.org/forums/topic/domain-mapping-health-status-for-domain-is-invalid

    This is on Siteground.com. I pointed the domain to the nameservers last week so it should be propagated. Per Dimitri's suggestion, I checked domain propagation before mapping and it did map but health status is still invalid.

    Initially, Siteground said that I needed to create the addon domain and use a subdirectory to put all the wordpress files into, which made no sense to me because it defeats the Multisite purpose, correct? Since downloading the Domain Mapping plugin, I pointed everything to the /public_html folder in cpanel. I also created a subdomain chapmansauto.levsites.com and also a wildcard *.levsites.com. I tried to remove the subdomain and wildcard domain but cpanel states that I have to remove the addon domain to remove the subdomain. I'm afraid to do that because I don't want to screw up the site that I've already built. I did back up the database just in case though. So at this point, I'm at a loss for what to do.

    I appreciate any help I can get. Thanks.

  • Jason

    Hey...I'm having the same issue. I've set the A-Record in GoDaddy to my server, but the mapping will not take (invalid).

    What do I need to make the following happen?

    Also, please ensure that the addon domain is using the exact same directory on your server as your WP multisite installation. This could be /public_html/ but it may varies on your case.

    If I'm just pointing the A-Record, what do I need to do on my server so that the site admins can map their domains with the plugin?

  • Adam Czajczyk

    Hello David!

    Your Multisite is a "subfolder" install so there's no need for wild-card DNS. The /chapmansauto site doesn't load though except its dashboard so that's the first thing to sort out.

    Therefore please for now remove mapping (mapped domain from sub-site), we'll get back to it later.

    At this point the levisites.com/chapmansauto site shouldn't load but it should show "403 forbidden" error. This happens because there's a folder /chapmansauto on the server that doesn't contain any website. Remove the chapmansauto.levisites.com sub-domain please and that should make it work, I think. It won't break/remove your entire site.

    The levisites.com/chapmansauto site should load now.

    The next step is to to go to the "chapmansauto.net" domain configuration and make sure that, since it's an add-on domain, it's root folder (sometimes referred as "document root") is set to be exactly the same as the root folder for "levisites.com" domain.

    Once this is done, type "chapmansauto.net" into browser address bar and see if it loads your main site (its signup page most likely). if that works, try mapping the domain again and it should now be fine.

    In case it was again showing that health status is invalide, please go to the "Network Admin -> Settings -> Domain Mapping" page and disable "Check domain propagation before mapping" and "Verify domain's DNS settings" options.

    Let me know if that helped, please.

    Best regards,
    Adam

  • David

    Hi Adam. First of all, thanks very much for your help. I was able to get the domain to map with valid status. Now, I can't get the chapmansauto.net to point to itself. The url points to the main url, levsites.com and the dashboard also points to the levsites.com dashboard. I've tried different combinations within the main admin screen > edit chapmansauto and it still points back to levsites. Did I do the wrong thing by creating this site before mapping it?

  • Adam Czajczyk

    Hello David!

    I checked the site and I see that you followed a different route that I suggested. To be honest, I'm not even sure how did you manage to map the domain to the main site as Domain Mapping doesn't support that and should not allow you to do this. Let's then get through this from the very beginning and please follow the steps below to the point:

    1. Remove mapping from the main site. The main site which is "levisites.com" should be available only under that domain.

    2. Edit your subsite (on "Network Admin -> Sites" page, by clicking "Edit" link) and set its Site URL back as it was, to : http://levisites.com/chapmansauto.

    At this moment there should be two sites and both should work fine: levisites.com which is your main site and the levisites.com/chapmansaout which is your sub-site.

    Both these sites should now be working fine and be available - their backends and front ends.

    Then simply go to levisites.com/chapmansauto dashboard, go to "Tools -> Domain Mapping" page and add your chapmansauto.net domain as mapped domain there.

    Kind regards,
    Adam

  • Adam Czajczyk

    Hello David!

    Well, experimenting with "every combination possible" - and as it turned out, impossible too - might not be the best solution

    I'll be happy to help you get through this and make it work but at this stage I'd need to access the site directly. Please do not make any further changes to the site whatsoever and send in:

    Subject: "Attn: Adam Czajczyk"

    - Mark to my attention, the subject line should contain only: ATTN: Adam Czajczyk
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - login URL and admin account login credentials (may be a temporary admin account) data
    - Include FTP log-in details (hostname, username & password)
    - Include hosting control panel access details (login address, username & password) - cPanel's usually the control panel used for this, but your provider may use something else; I'll need this for accessing your site's database, preferably via phpMyAdmin
    - Include any relevant URLs for your site

    Please use our contact form here https://premium.wpmudev.org/contact/#i-have-a-different-question

    I'll then make use of access credentials and try to make it work for you.

    Best regards,
    Adam