Domain mapping http https issue


Installed a SSL certificate on my multi-site and works fine on the main domain, only for the mapped domain it does not work. When I click the key under domainmappng settings it changes to https, but when I refresh it goes back to http.

  • Rupok

    Hi Vincent, hope you had a wonderful day.

    Is your SSL Certificate wildcard? Do you have a subdomain multisite or subfolder multisite? If subfolder, then your single SSL will work for main site and all subsites. If subdomain, then you will need wildcard SSL to work on all your subdomains.

    Now what I understand is, your mapped domains are not working under SSL, right? Well, any single SSL Certificate purchased for "" will work for "", "", "" but won't work for "". If your SSL is Wildcard, then "", "", "" etc. will work but in *no* case, it will work for "" which is mapped to suppose "" or "".

    But as you said, clicking on the key is not staying, this is weird. I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:

    Have a nice day. Cheers!

  • Vincent

    Yes it is a certificate listed for multiple domains. For now it has 4 domains listed and is expandable till 24 domains. Subdomains are not included.

    Strange thing is that sometimes it shows the green key, when I login into my admin but then it is not properly loading (see screenshot)

    Listed domains for the certificate are:

    Do you have a subdomain multisite or subfolder multisite?

    subdomain: --->

    I already enabled staff logging for another ticket, so you should have access.

  • Nithin

    Hi Vincent,

    Hope you are doing good today. :slight_smile:

    I checked your website, but due to the domain mapping settings, I'm being redirecting to the login page when I visit the subsite. I believe, the issue seems to be a bug which the developers are aware of when a https domain name with www prefix is used, it seems to swich to http.

    The workaround would be to map https without www as prefix, and then adding another mapping with www as prefix should fix the issue.

    Please let us know how that goes, if you still have issues, please disable the settings so that I could check your subsite. I'm marking this thread, so that you'd be notified when a new plugin update is available with this fix.

    Please let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.