Domain Mapping & IIS 7

Hey everyone,

I'm having some trouble getting domain mapping to work correctly on my site. I have a Windows server (IIS 7) with shared hosting (Godaddy) and a subdirectory install of WordPress 3.2.1.

I am able to see both the site and admin area of new sites. But, when I map a domain, I get a 404 error on the site's home page. All of the other pages are working correctly. Is there something specific I need in my web.config file?

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
<system.webServer>
<rewrite>
<rules>
<rule name="WordPress Rule 1" stopProcessing="true">
<match url="^index\.php$" ignoreCase="false" />
<action type="None" />
</rule>
<rule name="WordPress Rule 2" stopProcessing="true">
<match url="^([_0-9a-zA-Z-]+/)?files/(.+)" ignoreCase="false" />
<action type="Rewrite" url="wp-includes/ms-files.php?file={R:2}" appendQueryString="false" />
</rule>
<rule name="WordPress Rule 3" stopProcessing="true">
<match url="^([_0-9a-zA-Z-]+/)?wp-admin$" ignoreCase="false" />
<action type="Redirect" url="{R:1}wp-admin/" redirectType="Permanent" />
</rule>
<rule name="WordPress Rule 4" stopProcessing="true">
<match url="^" ignoreCase="false" />
<conditions logicalGrouping="MatchAny">
<add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" />
<add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" />
</conditions>
<action type="None" />
</rule>
<rule name="WordPress Rule 5" stopProcessing="true">
<match url="^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*)" ignoreCase="false" />
<action type="Rewrite" url="{R:1}" />
</rule>
<rule name="WordPress Rule 6" stopProcessing="true">
<match url="^([_0-9a-zA-Z-]+/)?(.*\.php)$" ignoreCase="false" />
<action type="Rewrite" url="{R:2}" />
</rule>
<rule name="WordPress Rule 7" stopProcessing="true">
<match url="." ignoreCase="false" />
<action type="Rewrite" url="index.php" />
</rule>
</rules>
</rewrite>
</system.webServer>
</configuration>

Any help is very appreciated. Thanks!

  • DavidM
    • DEV MAN’s Mascot

    Hi dleek and welcome to WPMU DEV!

    It's hard to say whether this is related to the configuration of Domain Mapping or IIS. I'll mention this to some other folks over here who might be more familiar with IIS (I've not used it myself).

    In the meantime, have you double-checked your settings for the domain mapping?

    Also, while the following thread doesn't provide a fix for the scenario mentioned, you'll find some useful information on IIS and Domain Mapping.
    https://premium.wpmudev.org/forums/topic/after-domain-mapping-312-site-domain-shows-generic-iis-home-page-and-not-blog-content

    Cheers,
    David

  • Derek
    • New Recruit

    Hey David,

    Thanks for the reply and further information about IIS. IIS has been a little tricky. After digging in further and then taking a step back, I realized that my home page had been switched to a "Draft" instead of "Published."

    That explains why I could see all the other pages, but not the home page. I remember I had switched it because all my pages were showing as "Scheduled" after I had published them. I must have forgot to mark that one "Published" when I was fixing them.

    One other thing I changed was the slug of the home page. It was similar to another subdirectory and I wanted to make sure they weren't conflicting.

    Thank you for your help.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.