Domain Mapping infinite loop when logged in on main site

Hi guys,

I am using Domain Mapping plugin.

I have a problem about infinite redirect loop on my mapped domain.

When I am logged in on my main site , then I try to visit my mapped domain, it seems that I am getting an infinite loop.

But when I try to log out on my main site, I can view my mapped domain successfully.

Another instance is that when I logged in on my mapped domain, I don’t get that infinite loop.

So basically it only happens when I logged in on my main site.

So it’s like, my main site is: http://mainsite.com and I logged in there as an admin, then when I go to my mapped domain which is http://mymappeddomain.com , I am getting that infinite loop.

What seems to be the problem here? Any help on this please, your help will be greatly appreciated!

Let me know if I lack any details and I’ll provide it right away.

Thanks! :slight_smile:

  • Ash
    • WordPress Hacker

    Hello @smithstudios

    Welcome to WPMU community!

    I hope you are well today and thanks for asking the question.

    Please post a screenshot of your Network Admin > Settings > Domain Mapping page.

    Also, would you please grant support access from your Dashboard > WPMU DEV > Support > Support Access so that I can check?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    I will be happy to take a look :slight_smile:

    Cheers

    Ash

  • SD2k
    • The Crimson Coder

    I’m sure you have also already commented these lines out then?

    /*define( 'DOMAIN_CURRENT_SITE', 'venturecore.org' );
    define( 'PATH_CURRENT_SITE','/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );*/

    Just checkin!

    I had this problem too but I was able to resolve it. One other thing I have running is WPMUdev’s “Remember Me” plugin active.

    I will say this though. I never login to a site(s) from the same browser if I’m logged in with the superadmin on the main site and the superadmin has been added as a ‘user’ on the subsite (mapped site). In this case you need to remove the superadmin as a user on the subsite from subsite standard admin dashboard.

  • stjert
    • WPMU DEV Initiate

    Hi @sdinvestor2k

    Here is my wp-config code:

    /*define('DOMAIN_CURRENT_SITE', 'mysite.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);*/

    define('ADMIN_COOKIE_PATH', '/');
    define('COOKIE_DOMAIN', '');
    define('COOKIEPATH', '');
    define('SITECOOKIEPATH', '');

    I still have that problem even if I have that configuration on my wp-config.php

    I’ll try to install ‘Remember Me’ plugin and see if that would resolve my problem.

    Thanks! :slight_smile:

  • SD2k
    • The Crimson Coder

    Very strange. Sorry to hear, I know things like this can be frustrating until you find the solution.

    I would definitely activate support like @ashok suggested so they can look at your configuration in the backend.

    If I have any revelations I’ll let you know. I did go through something similar but you might have something setup that is different than I have right now.

    I also remember I had to wipe my browser cache’s and site cache clean as well. Once in a while I have this problem but only when I’m logged into the primary site as superadmin and superadmin has a role on the subsite also.

    I have also gotten into the habit of using separate browsers and I really like using Chrome’s ‘users’ feature as well. It’s just easier to manage when you have 12 Networks and 67 sites. I setup a ‘user’ for each network in Chrome and it helps to keep things separated.

    I hope you find a solution.

  • Ash
    • WordPress Hacker

    Hello @smithstudios

    Yes, I can see the issue. It seems either a plugin conflict or cache issue.

    #1. Please delete cache from plugins, browser cache, server cache and deactivate the caching. You may need to comment any line (if any) in wp-config.php that is related to caching.

    #2. Then, would you please run a plugin conflict test? Please deactivate all plugins except this one and check if you still face the problem. If not, then enable one by one and check which one is causing the problem. You can see the flowchart here: https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    #3. Also, check if you have any script in mu-plugins folder.

    Please let me know what you get.

    Cheers

    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.