Domain mapping invalid

Hello, I have been using WPMU just to try on my brand new VPS server, It is very slow when I am using any plugins from WPMU hopefully I will see more improvement. What I need you to look at is "domain mapping" I have never had success .

I need to connect this domain for example: http://demo1.demo.com to http://demo1.com/ . From my demo on dashboard, Tools - Domain Mapping - I have entered "Map new domain name" the result of "Health Status" is "Invalid." So why invalid? When the domain name I wanted to redirect to is fully working also, it uses the same IP address or name server.
Thank you.
Regards
Bancha

  • Nithin

    Hi Bancha,

    Hope you are doing good today. :slight_smile:

    Could you please confirm whether the DNS change been full propagated? Upto 72 hours, the health status invalid could cause because of this.

    You might find the thread helpful:
    https://premium.wpmudev.org/forums/topic/solution-domain-mapping-health-status-invalid

    Also, please refer the usage guides, to check whether you have missed out anything:
    https://premium.wpmudev.org/project/domain-mapping/#product-usage

    Please let us know how that goes, so that we could give a closer look. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Bancha

    Hi,
    I read a lot of the tutorials, and the links you sent but it hasn't solved my problem.

    So, I contacted with my hosting provider and confirmed that I have two IP addresses something like as below:
    Ip: xx.xxx.xxx.22 > this share IP
    Ip: xx.xxx.xxx.220 > this dedicated IP

    When I signed up, they sent me a welcome email with name servers and IP details, etc. (VPS) The name server will look like as below:
    NameServer1: nsxxxxxxxx22.a2dns.com
    NameServer2: nsxxxxxxxx220.a2dns.com

    Then log into domain name manager and change name server to "NameServer1: nsxxxxxxxx22.a2dns.com" and "NameServer2: nsxxxxxxxx220.a2dns.com". Here when I checked the DNS lookup , all the domain names were assigned to "Ip: xx.xxx.xxx.22" "(share IP) except a website that has multisite installed IP is: xx.xxx.xxx.220 . I have asked them again, can I made all the domain names assigned to "Ip: xx.xxx.xxx.220 > this dedicated IP"? they said it is not impossible.

    1. My situation is how can I point all the domain names automatically to Ip: xx.xxx.xxx.220 (dedicated IP)is that the same as multisite used? while using the same name server.

    2. Or do I have to add every single domain name DNS Record? Is that correct? (as a picture is my DNS Management) Thank you.

    Regards
    bancha

  • Ash

    Hello Bancha

    Let me simplify the procedure.

    For example, your main site is network.com
    You have two subsites:
    1. one.network.com
    2. two.network.com
    These two subsites you want to map with following domains repectively:
    1. one.com
    2. two.com

    So, if anyone enter one.com in the browser, it should show the site of one.network.com. Same for two.com

    So, there are two scenarios now. Either you own all the domains, or you don't. First I think you own all the domains.

    network.com site is hosted in a hosting whose nameservers are:
    ns1.networkhost.com
    ns2.networkhost.com

    So, you have entered these nameservers for network.com domain panel. You have to set same nameservers for one.com and two.com domains too.

    Then you will add one.com and two.com domains as add on domain in the same hosting of network.com, and make sure you point them to the network.com wordpress root folder. So that if any one enter one.com or two.com it shows network.com site.

    After that, you will add the domains in corresponding subsites using domain panel plugin, and the mapped domain will start working.

    Now, if you don't own the domains, then you will need a dedicated IP. I know you won't have access to the domain panel of your customers so that you can't set name servers in there. So, you will pass them you IP and they need to set a DNS record for their domain and point to that IP. Only then domain panel will work.

    But to use IP, make sure the IP is pointed to the main site. That being said, if you enter the IP in the browser, then the main site should load.

    2. Or do I have to add every single domain name DNS Record? Is that correct?

    My situation is how can I point all the domain names automatically to Ip: xx.xxx.xxx.220 (dedicated IP)is that the same as multisite used? while using the same name server.

    You need to add A record in the domain panel for each domain and point to that dedicated IP.

    Hope it helps :slight_smile: Please feel free to ask more question if you have any.

    Cheers
    Ash

  • Bancha

    Hi Ash,
    Thank for the response I very appreciate that. Yes, I own the domain name, I followed step by step as above,
    1. Both parties have the same nameserver
    2. I have added "Addon Domain" via cPanel on the same hosting and in the same WordPress root folder.

    3. On the last step, after mapped on subsites panel "Tools" - "Domain Mapping" I still get the same issue "health status Invalid" so what do you think? Should I reinstall "Domain Mapping" plugin? Thanks again.

    Regards
    bancha

  • Kasia Swiderska

    Hello bancha,

    Does health status prevent from adding mapped domain or domain is added and shows that health status is invalid?
    If first, try to disable those options in Domain mapping "Check domain propagation before mapping
    "

    If second - that can happen - even if domain is mapped correctly status will be invalid because some servers are blocking connection that is checking that status.

    If this is still not working would you mind allowing support access so we can have a closer look at this? In support message leave info what domain to what subsite you are trying to map
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    kind regards,
    Kasia

  • Ash

    Hello Bancha

    The mapped domain http://harrys............com.au/ is pointed to somewhere else. I just removed the mapped domain from your network, and still I am getting 403 forbidden error. When you added domain, did you point it to same folder where the main site installation is?

    In cpanel, when you add as parked domain, by default it points to main domain root. But when you add an addon domain, it points to a new folder, you need to manually remove that folder and point to main site root folder.

    Do you confirm that you did above?

    If so, then I need to check your cpanel. In that case, would you please send me admin login and cpanel login details?

    To send me details, please use our contact form: https://premium.wpmudev.org/contact/

    Select: I have a different question
    Subject: Attn-Ash (this ensures that it will be assigned to me)
    Details:
    1. Send all requested details
    2. Send a link of this thread so that I can track
    3. Send any other relevant link

    I will be happy to take a look :slight_smile:

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.