Domain mapping invalid (site not installed)

Hi. This is a cry for help ! I have a website going public on monday and I need in to be up and running by this sunday.

Here's the problem :
- on https://t3r1.fr/ I have a multisite, with bp install
- I created a subsite https://t3r1.fr/vdm/ and I've been working on it
- I bought the domain http://vdmere.fr/ and installed domainmapping

Case 1
- I configured a DNS "A" record pointing at the IP address of my server (my host is french OVH)
- I mapped vdmere.fr to my subsite but it says "INVALID"
Case 2:
- I also tried configuring mapping vdmere.fr to the /vdm/ folder through my host, as my host has a multisite hosting option to do exactly this, but it still says "invalid"

- in both cases, I get an error (site not installed)
- my site works fine on original url t3R1.fr/vdm/wp-admin and front end
- my site is mapped correctly since permalinks screen tells me the site URL is vdmere.fr

I'm lost... help ?! I'm going through the threads and google but can't seem to find a solution

  • Sajid

    Hi pravdamien,
    Hope you are doing good today :slight_smile:

    First of all make sure the mapped domain is pointed to the main site folder and not subsite on. That is, it must point in the folder where you have installed WordPress.

    Now, some times, host does not report the status of domain correctly. So you can disable this check check from Network -> Settings -> Domain Mapping -> Mapping Options -> Check domain propagation before mapping.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,
    Sajid

  • pravdamien

    Thanks
    This worked perfectly

    For future reference, to anyone who might stumble upon this thread :

    Domain mapping must point to the domain name OR folder where WP is base installed.
    For example, in my directories i have several root installs :
    /IndependantSite1/wp
    /IndependantSite2/wp
    /www/

    the /www/ was the one i was looking for. and Subsite being mapped was mysite.com/subsite >>> subsite.com
    I tried pointing to either mysite.com/subsite or www/subsite or root /

    All three were wrong. The answer was pointing to /www/

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.