Domain Mapping isn't working with Manage WP

Trying to add a mapped subdomain to ManagedWP. The ManageWP SEO option can't check rankings on the mapped domain.

The Managed WP support team replied:
Since this is the case, you should configure your domain mapping plugin and enable the 1.Remote Login option and 4.Redirect administration pages to the networks original domain.

If your domain mapping plugin doesn't have these options you should use this one and then the website should be connected successfully.
https://wordpress.org/plugins/wordpress-mu-domain-mapping/#installation

Please advise

  • Predrag Dubajic

    Hey Mark,

    Hope you're doing well :slight_smile:

    I have created ManageWP account to test my network with mapped domain but I'm afraid that the SEO plugin is not free so I was unable to test with that specific one.

    I did perform free security and performance tests and those finished without any issues.
    Can you tell me if these scan work for you as well or they work fine so that the issue is specific to SEO scan?

    In my Domain Mapping settings I have "domain entered by the user" set for both Administration and Login mapping, and I have "Cross-domain autologin" enabled as well.
    Can you see if SEO scan works for you with these settings?

    Best regards,
    Predrag

  • Mark

    Hi,

    From what I can gather, ManageWP 'sees' each site as just that, an individual site, not as a network install as such -- I'm guessing it's a way for them to charge per site for their add-ons rather than the whole install paying one price per add-on, or is that just me being cynical? :grimacing: The issue I am having is with a sub-site other than site 1 I should point out, although probably doesn't make much difference. Site 1 is working ok in ManageWP, (which is not domain mapped) and site 2 is not working (which is domain mapped).

    I may have confused the issue mentioning the SEO add-on, my concern with that is you'd want their SEO add-on to use the domain mapped domain, not the original domain as it makes no sense (to me) to report on rankings for mysite1.somedomain.com when your public facing name is http://www.thisismypublicfacingsite.com. I did try to clarify this with ManageWP support but didn't really get a direct response to how that works, they did send the following though.

    "...all we need for the website to be connected is the ability to log in remotely and that the administration pages can be reached on the networks original domain."

    I would be more than happy to add you as a user to my ManageWP account if you want to have look at my setup and test with any of the add-ons, but obviously, I won't be posting credentials for that on a public forum.

    Mark

  • Sohag Ronjon Dey

    Hi Mark,

    Thanks for your repy and I hope you are having a beautiful day. :slight_smile:

    From you message it suggests that the seo addon is not working only for the mapped domains. I can see that you have set original domain for administion mapping and loggin mapping in domain mapping settings which matches their requirement of reaching administration pages on original domain. Have you tried the setup mentioned by my colleague Predrag that is "domain entered by the user" set for both Administration and Login mapping and enable "Cross-domain autologin".

    Please send your details through our contact form so I can try to investigate this further,https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Sohag"

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me

    Please let me know when you do so.

    Cheers,
    Sohag

  • Mark

    Hi,

    Just wanted to add to this for anybody finding it, the problem appears to be something other than Domain Mapping related as I'm having the issue on several non-MU sites as well. No issue found as yet though despite the WPMU Dev, Cloudways and ManageWP support guys all looking at it and can't find what's causing it. Has to be one of those three doing something odd though I guess. I'm still sticking with Defender for the time being and hopefully, the problem will get fixed at some point.

    Mark

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.