Domain Mapping issues and question about using SSL on multisite

Issue 1: I mapped a domain to a subdomain and the recaptcha on the login page was messed up, so I wanted to remove the recaptcha, but couldn’t find where to do so and now I’m getting an ERR_TOO_MANY_REDIRECTS error in that page.

Issue 2: I’m getting a ‘Page not found’ error on the /wp-login.php page of the same site.

Question: I have a multi-site with the subdomain option (my subdomains are domain mapped). I have SSL certs for some of the sites. With the domain mapping, it's easy to force SSL on subsites, but how can I force SSL on my main site without it affecting all other sites?
SSL is active for some of my sites but not for the main site and now I'd like to add SSL to the main site without affecting the subsites that don't have it enabled (I don’t have a wildcard to use in the entire network, I only have individual SSL certs).

  • Nastia

    Hello David

    Hope you're doing well!

    Issue 1: I mapped a domain to a subdomain and the recaptcha on the login page was messed up, so I wanted to remove the recaptcha, but couldn’t find where to do so and now I’m getting an ERR_TOO_MANY_REDIRECTS error in that page.

    The ERR_TOO_MANY_REDIRECTS showing up because the /portal/ page redirects to the /portal/login-page/
    I've quick edited the "Login Page" and removed "Portal" parent page and the Login Page is loading from my end

    Issue 2: I’m getting a ‘Page not found’ error on the /wp-login.php page of the same site.

    I can't reproduce this error on the mapped domain's log in page. The /wp-login.php is loading without an issue. If it is will show up an error on your end, please clear the browser cache and try again.

    How can I force SSL on my main site without it affecting all other sites?

    Please install SSL certificate only for the main domain, and go to Domain Mapping settings, under "Force http/https (Only for original domain)" choose "Yes" and " Force https".

    You can also enable the WordPress Force HTTPS plugin on the main site only, in case of mix content errors:
    https://wordpress.org/plugins/wp-force-https/

    The plugins works well along with the Domain Mapping plugin.

    If the above solution will not work, please add the following rules to the .htaccess :

    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^example\.com [NC]
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://www.example.com/$1 [R, L]

    Make sure to replace example\.com and http://www.example.com with the domain name you're trying force to https

    Please let me know how it went!

    Kind regards,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.