Domain mapping" link under Tools-Domain Mapping is missing

Hi Supporter, For some reasons "Domain mapping" link under "Tools -> Domain mapping (on sub site) is missing? How would I fix this? thank you.

  • Dimitris

    Hey there Bancha,

    hope you're doing good and thanks for reaching us! :slight_smile:

    Could you please double confirm that you've completed the installation steps as described here?
    https://premium.wpmudev.org/project/domain-mapping/#product-usage

    Also, in previous link, please mind this part:

    Dedicated IP: For using A Record setups, you need to ensure you have a dedicated IP. This IP would fall onto your multisite setup. i.e. when you enter the IP you see your multisite. This is known as the DocumentRoot for the IP, your host will be able to sort this quickly and easily.

    I noticed that if I visit the IP address that Domain Mapping plugin is catching in network admin area Settings -> Domain Mapping, then I redirect to another domain name rather than the main blog of this multisite installation.
    Could you please ensure that the main domain that's used in multisite has set its DocumentRoot to the actual folder of the multisite installation? This is /public_html/ folder in most Apache/cPanel installs but you may have to contact your hosting provider for more help on this, so your IP address point to your multisite installation rather than another domain.

    Warm regards,
    Dimitris

  • Adam Czajczyk

    Hello Bancha!

    I took a liberty of accessing your site using support access that you granted and I checked it.

    There's a Pro Site plugin installed on your site with three levels defined. None of the sub-sites however is the Pro Site site, they are just "regular" sites so in terms of Pro Sites they are "free" sites - with most basic features. That's the idea of Pro Sites: there are premium sites (levels) that you charge users for and a "free" site with a limited features.

    On "Network Admin -> Settings -> Domain Mapping" page mapping functionality is set to be available only to Pro Sites levels (pro sites sites). If you make any of the sub-sites a "Pro Site" site or create a new sub-site via Pro Site checkout - selecting one of Pro Site levels - it should have the "Tools -> Domain Mapping" page available then.

    Best regards,
    Adam