Domain Mapping not redirecting to WP site, but URL is right

Hi there,

I've installed this plugin on my multisite network and I'm trying to get the site up and running for my first mapped domain, but I've found that when I try to load the URL, instead of redirecting to the WP site, it instead goes to the default Apache no files page (i.e. my empty hosting account). When I go to "visit site" from the WP dashboard of this site, it redirects me to that page also and so I'm sure there's something I've missed somewhere.

I have my multisite website on the same IP as the domain I'm trying to map (albeit on a different hosting account) and so I'm wondering if that is complicating things perhaps? I can use another DNS if need be but I'd like to know what the trouble is first before going that route as the domain I'm trying to map has my e-mail etc.

I have a number of my own domains that I'm planning on putting onto this multisite install to make my domain management a little easier, and I saw a mention of the 'Addon Domains' plugin under the multisite usage info but I can't seem to locate that plugin so perhaps it's not available right now? Not sure if this is something I need or not.

Thanks in advance for the help!

Ingrid

  • chodhry

    Did you check it on a proxy? Did you check it with and without www?

    I had this problem with my multsite install. Things I had to make sure were

    My multi site install is on a dedicated ip and not shared.
    my addon domain has a proper A record pointing to the above IP. Usually you have an A record already pointing to the ip of your host and you need to edit that. That is what I did to properly map my domain hosted on another server.

    I did see that error for few days and kept asking my host. They recommended to flush DNS of my local machine. I did that and ever since problem has been gone.

  • Hiranthi

    Could also mean that the server doesn't know that all domains that point to the IP-address should be handled by WordPress (ie: the wildcard domain is missing in vhost.conf).

    So: for using Multisite with subdomains you need a wildcard subdomain in the servers' DNS. For domainmapping you need a wildcard domain in the servers' DNS, this isn't automatically added.

    I have no idea how to do this btw (I've had andrea_r do it for me, my hosting provider has done it for my other server), but I do know that it won't work without the wildcard domain because the server won't know where the domain should point to without it.

  • Ingrid

    Hi Tom,

    The steps that I took were exactly what was posted in the Usage instructions:

    You are running your WordPress website as a multisite right? Yes

    Yes I have a dedicated IP

    Plugin installed, sunrise.php moved to content folder and wp-config.php updated with define( 'SUNRISE', 'on' ); and plugin activated just fine

    Updated settings with my own IP but I know this is just for cosmetic purposes (and my domains are all on the same IP regardless)

    Don't have Pro Sites installed

    Both Administration mapping and Login mapping have been set to "Domain Entered By The User"

    I've added a site and mapped a domain to it. As I mentioned, the IP is the same and so adding the A record was skipped because the record already existed. If you dig the record of my mapped domain you can see that for yourself. I've flushed my local DNS cache too, just in case (thx for the suggestion @chodhry) and both using www and without resolve to the same empty hosting account Apache index page instead of the multisite sub-domain installation.

    I have a feeling that @Hiranthi is on the right track, considering that the domains are on the same host and IP already, and the A record exists, would like to know further details. I can investigate the Apache man pages but if someone had done this before successfully I'd love an example config for it / instructions. I have another couple of multisites that I'm going to be setting up soon so I'd like to get my head around this properly. :slight_smile:

    Thanks for the help, all!

  • Barry

    Your URL that is mapped isn't set up correctly I'm afraid. When I visit the mapped domain in your screenshot I get a white page showing the index of a url. This means that the domain isn't set up in your webserver to point to your main wordpress directory.

    Do you have a control panel installed on your server? Other than that, yes, it's going to be messing with apache vhost settings. You basically want to set up the mapped domain as an alias of the main site domain.

  • Ingrid

    Hi Barry,

    Thanks for the response - I think I mentioned a couple of times that I'm getting redirected to the (empty) hosting on my web server instead of to the WP site that's mapped, the question is, how do I set it up correctly so that I don't keep getting redirected to the empty hosting account on the same server / IP?

    I have cpanel access and a reseller hosting account so I'm not afraid to change the Apache config (I was a linux sysadmin a long time ago) but I think in my last note I asked if I could get a sample config or some instructions on how to do this, I can go and read the man pages but if someone who knows how to do it already could point me in the right direction to save me some time I'd really appreciate it - could you help me out with that please?

    Thanks!

  • Ingrid

    Hi all,

    Thanks for the help but I finally figured out what the problem was, it's kind of a strange setup that I have in that I have a reseller account and have my nameservers set up on a particular domain, but I had set up the multisite installation on another domain within my hosting account because it was for managing my own sites and therefore I didn't want it to be configured as a sign-up service.

    So as it turns out, when you have a multisite installation and have more than one hosting account on the same IP, you need to park the domain you want to map under the domain where the multisite is installed, it can't be a hosted domain unto itself (unless it is hosted elsewhere with another IP). I didn't know this and it took quite a bit of reading to figure it out so hope it will help someone out there because it was driving me mad but I guess I should have figured it out earlier. I opened a ticket with my host and it took 3 frustrating days (in which they offered to charge me extra money) of back and forth to get to this answer

    Anyway, thanks all for the help and now we know for next time I guess.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.